After upgrading to a Pixel 8 Pro, notifications no longer work

I have confirmed that notifications are enabled in the Android app.

I've tried removing the phone from the hub and sending a geo event to force it to be reinstated.

I've uninstalled and reinstalled the app. There are no notifications in the tools menu.

The name of the device in Settings matches my device name.

Please let me know what else to try.

I recently updated to a Pixel 8 Pro and my notifications are working fine. I'm using 1.6.12 of the mobile app.

Did you correctly reselect the device for your phone in the app? In the app, go to settings, Hub, reselect your hub, and then select the correct device. Then try sending a test notification from the web UI for the device.

Alternately, you can go to the same screen in the app and try to create a new device for your phone.

There was only one device in the app. I've tried deleting and recreating a number of times.

I can't find a way to send a test notification from the Hubitat UI. I can do this from Webcore, however.

Still no luck. Anything else I can try?


I realized that I can send a notification from the Pixel 8 Pro Device page in the app. I've tried this and it works!

However, I am still not receiving other notifications. I should mention that all other notifications come via pistons on Webcore.

1 Like

Okay, I've resolved this.

I realized that I need to let Webcore know which devices to push notifications to!

Thank you for your help.

1 Like

I always forget to do that when I upgrade my phone as well.

Thank god for the "Swap Apps Device" option in Hubitat! (just wish it worked with Child devices.. :frowning: )

I too just got a Pixel 8 Pro. No issues with notifications or needing to create a new mobile device. When logging into the app, after you pick your hub just pick your old phone.