After update to 2.0.9.133 z-wave dimmers don't work


#1

I just updated to 2.0.9.133. After doing so any time motion lighting should turn on one of my Leviton VRMX-1LZ dimmers I get the following error in the logs:

app:1332019-05-13 07:42:48.814 pm errorjava.lang.IllegalArgumentException: Command 'setLevel' is not supported by device. (motionActive)

Could this be related to the fact that these dimmers show up as "Leviton fan controller" despite being dimmers? They have always worked fine in the past before this update.


#2

Yes, this is new as Hubitat fixed the fan drivers and it no longer works for dimmers. You can try the Generic Zwave dimmer driver as device type (worked for me but I have Leviton VRPD3-1LW) If you do a search you will find several threads about Leviton devices. Some will include drivers from Smart things that seem to work quite well.


#3

Yep I changed them all to Generic Zwave dimmer and they work fine now.