Aeotech siren 6 not responding

I noticed the siren stopped working yesterday. I tried playing a sound manually through the hubitat with no luck. I checked the power supply and is indeed working (tested with voltmeter). I even unplug it and the tamper alarm didn't go on as usual when I moved it around. I tried testing the back button, resetting it but is completely dead. Here are the logs from hubitat:

Any suggestions?

I forgot to say that the Zwave detail page in hubitat setting doesnt pick up the Siren signal. Its just blank.

The device is dead. This has been reported earlier with the Siren/Doorbell 6.

It's back up and working!

This is what I follow from Aeotec support email:

Try performing a hard power cycle on your Siren 6 by performing these steps:

  1. Remove power from the Siren 6

  2. Wait 6 hours for the battery to completely drain out (overnight works)

  3. Power up your Siren 6 and see if your Siren 6 comes back into operation.

If it does freeze up often, i would recommend firmware updating it to optimize the coding used in the Siren 6 which should resolve the freeze issue if you encounter it often

Download the Hubitat app