Aeotec Series 7 Recessed Door Sensor

Does anyone have experience with these? I have two open, swapped each battery and then replaced with a brand new Lithium one. I get them to connect, but the status doesn't seem to update once it starts up. The light is turning on and off when the magnet gets close so I have reason to believe the sensor works. Neither will update in a timely manner that the sensor is open. (like 15 minutes later I look back and it may say open. I tried to update firmware on the sensor to 1.05 from 1.04 but it's not working. Same goes if it says open, won't update timely for closed. Any thoughts? I am pulling what few hairs out I have left. Hubitat was updated to latest version today as well, so it's not an old version and did it on both.

Yes, I have 3 or 4 of these. It's a bit tricky to get the firmware to update. Here is what the Aeotec support guy suggested in another thread in the forum. Steps 1 and 5 are if you use the older (driver, non-app) version, omit those. The key part is 2, 3, and 4, which wakes the device up. Worked for me.

  1. (optional but highly recommended) - Move your sensor as close as 10ft/3m from your hub with direct line of sight, ensure the best communication signal between your hub and Recessed Door Sensor 7 (firmware updates require a lot of communication to complete).
  2. Change the device type to Z-Wave Firmware Updater (binary version) - driver itself doesn't have "no more information frame" sent to put the sensor to sleep when you wake it up.
  3. Press and hold the action button on RDS7 (Recessed Door Sensor 7)
  4. When the LED lights up, release the action button.
  5. Ensure that the LED remains on, this indicates that it is awake.
  6. Enter the hyperlink for the firmware update for your sensor
  7. Start the update - the update should begin right away.
1 Like

What version of firmware are you using on these? Also are you using the Hubitat firmware updater or something else?

I am using 1.05. Used the built-in Device Firmware Updater app. There is a “feature” of the DFU app that causes it to sometimes get wedged, you have to delete and reinstall the app to recover. Doesn’t lose firmware files you have uploaded.

Also, the trash can icon to delete files is way off on the right side, can’t get to it unless on a computer with big monitor. Unusable on iPad or mobile phone.

After doing the update, I had to change the driver to “Device”, save, configure, deleteAllStates, change driver back to Aeotec Recessed Door/Window 7 Series, Save, Configure. Otherwise, I couldn’t get the Hubitat driver to realize that new firmware had been applied. Your milage may differ. May have had to reboot the hub, don’t remember.

Update seemed to take 15 to 20 min. if the sensor was fairly close to hub; may take years otherwise.

1 Like

Just tried this again, the battery life on these are the worst :sob: so expensive