Aeotec Range Extender 7 Ghost Issue After Firmware Update

I have 3 Aeotec Range Extender 7. I updated the firmware via the OTA firmware update app in HE, and I thought all was well. When I checked on them, all the LED’s were “breathing”, and they were not responding to anything in Hubitat - so I figured I needed to exclude and include (which is probably where this went off the rails). So I excluded them, and they did not respond (I guess?), so the UI presented my with a “Force Exclude” button - I used that, and no error was mentioned. At this point I should have stopped and looked at the ZWave Details page (I’ll bet). Then I factory reset them and added them into Hubitat with no issues. Now it seems I have 3 “ghosts” left over from he original repeaters.

Any ideas on how to get rid of these without using a ZWave stick (which I just ordered, I thought I could get by without one….)? Selecting “remove” in the ZWave Details UI just results in the following log messages (or completely locks up the ZWave radio, requiring a “power down and chill out”. Open to any ideas and suggestions on how I could have done this process “better”.


First thing I would try is, unplug the range extenders, go to settings and shut down the hub, once the hub has safely shut down remove power from the wall for 30 seconds to a minute. Then power the hub back up and try the remove button again while leaving the range extenders unplugged.

3 Likes

What @byarnell05 said... If that doesn't work you can try letting the hub do it's nightly maintenance and see if it clears. After that you will need a z-wave stick paired as a secondary controller to remove them. Hopefully you don't need to go that far.

I did firmware updates on six of the Aeotec 7 range extenders. Some of them were initially paired with S2 security, so I excluded them from the mesh, reset them to factory, and included them once again, but without security. That made the upgrade process go a lot faster.

After the upgrade, the devices are seen as new, but the former devices are not removed so they end up as ghosts. Before attempting the firmware upgrades, I purchased a Zooz Z-wave USB stick with the 700 series chipset. It worked great in removing the ghosts. Supposedly, the Hubitat C7 hub can remove ghosts, but I have found it to be hit or miss. The Z-wave stick is much more reliable. You can download the required Simplicity Studio 5 software from Silabs. There is a learning curve to using the software, but it is not too difficult.

Thanks for this, but no luck!

Your experience is similar to mine. I’ll wait for my stick and remove the ghosts that way.

Does anyone know of a way to update the firmware on the Aeotec range extender 7 and NOT end up with ghosts?

for my 4 RE7s, I've updated the f/w at least twice so far (maybe 3x?) using the stock HE firmware updater, and I've never ended up with a ghost.

I seem to recall having to exclude/reinclude after the latest (1.05) update in order to get the correct f/w value to show up in the HE details page, but I don't think I did that for previous updates... And I may be confusing that with a different z-wave device update experience - they all start to run together after a while!

ETA - no idea if it's a factor or not, but mine are all paired "None" security (and always have been).

1 Like

I have several '6 and one '7 version and have never updated FW on them, but in general doing a FW update should not generate ghosts.

I think I have heard that on Zooz devices (@erktrek - need your help here) there may be a need to exclude and re-included devices you update. I haven't followed the details closely since I only have any Zooz device, and it came w/the current FW when I received it.

2 Likes

Sad, it might be worth a shot to try and remove the "new" devices first and then try and remove the ghost devices using the method I outlined earlier. I've never tried to remove a ghost node when there was also an "active" version of the same node. Worth a shot if you don't want to wait for your zstick to show up.

FWIW, I have an Aeotec Range Extender 7 that was on FW 1.3. Just updated it to FW 1.5 using the HE Device FW Update app.



After update:

Not seeing any ghosts or problems. Reloaded the Z-Wave Details page and it looks normal.

2 Likes

What firmware version is listed? Does the repeater have a steady LED, or is it “breathing”?

I don't get a FW version in the Device page either before or after the udpate. The FW updater screen I posted above shows the 1.05 version that I downloaded and successfully applied.

image

If you don’t mind, try 2 things. Try to get the metadata from the device on the firmware update page (should return the firmware version). Also try selecting “refresh” on the details page for the device - that is how I got the firmware version to display.

I had already tried Refresh and reloading the Device page several times - FW version still not appearing. Tried again a few times, no change.

Oddly - the FW update tool seems to still be seeing 1.03 on the Range Extender 7:

That is not so good looking - haven't had that happen before w/a FW update.

The update did complete in terms of what the UI reported:

Yeah, that's all looking very familiar now lol - but I just can't remember if I ran into this with my latest RE7 update or when I did my latest Zen17 update... It was one of those two though, I'm pretty sure.

IIRC, an exclude/include popped it all back into place without having to try another update -- the f/w version then showed accurately on the details page, and the f/w updater tool reflected the proper current f/w too.

I'll be curious to see if that (or something else) works for you -- it'll add to the ol' bag of tricks for next time!

ETA - I'm pretty sure this happened to my with my Z17 - now I remember having to rebuild a bunch of dependencies/rules once I reincluded it. But that exclude/include definitely cleared it all up - just sucks that it's such a nuclear option. Though not as big of a deal with a device like RE7 (since it's likely not tied to many rules/automations).

Try sending a config signal to turn the LED on (or off). Does it respond?

1 Like

Rebooted to see if that would give me the correct FW that I thought had been updated...now this:

Don't have an option to do that on the Device page. Using the Generic Z-Wave Extender driver. Light is currently On on the extender...don't remember if it was On or Off before I started the FW update.

I think light is on by default. I forgot I use Denny's custom RE7 driver for these - it has a LED toggle.

Was not aware...I'll look for it.

Driver doesn't control, and found that the light is actually blinking, not solid, so it appears to not be connected...I assume that's pairing mode? (Been a while since I paired it, dont' remember how it behaved).

Removed it from the Z-Wave Details page using Remove button, worked the first time. Removed on the Device page as well.

Download the Hubitat app