Aeotec MultiSensor 6 SetParameter

I have one of my multisensor that eats the battery fast because it detects tons of motions. I read on Aeotec site that I can update parameter 4 (length 1) to 0 to disable the motion. I tried using SetParameter in @csteele driver but it does not work. Somebody did that before ?

It doesn't have disable. The range is 0-5.

Screen Shot 2021-07-21 at 11.50.28 AM

the last two columns are: 5 is default and it's 1 byte in length

It matches up with the set of selections offered in the Sensitivity drop down:

Screen Shot 2021-07-21 at 11.52.15 AM

Thank you for your answer. I got that from the online manual:

Parameter 4 [1 byte] will determine the sensitivity of the motion sensor from a value range of 0 disabled to 5 max sensitivity (your ability to configure this setting will depend on the gateway used).

My response was from the v1.13 technical manual.

It's possible they refined either the meaning or the clarity of what "0" does. :slight_smile:

I've updated "my" driver to allow for 0 "Off"

v2.0.2

:slight_smile:

Thank you !

Your change works !

But did you try to use Set Parameter for parameter 4. It does not work for me

image

Firmware v1.15 seems to be available..

Also just noticed the info on v1.14

V1.14 Changelogs:

  • Basic Set faster report trigger when motion detected (when Parameter 5 [1 byte] = 1)
  • Support new hardware light sensor Si1133
  • Backwards compatible to older light sensor Si1132 (used in firmware V1.13 and under)

Yes, it worked for me:

dev:845 2021-07-21 03:31:12.276 pm debug ---CONFIGURATION REPORT V1--- MultiSensor6A (officeDesk) parameter 4 with a byte size of 1 is set to [0]
dev:845 2021-07-21 03:31:07.254 pm info  Motion is inactive by SensorBinaryReport

Setting it to 3 works too:

dev:845 2021-07-21 03:32:41.439 pm debug ---CONFIGURATION REPORT V1--- MultiSensor6A (officeDesk) parameter 4 with a byte size of 1 is set to [3]
dev:845 2021-07-21 03:32:41.045 pm info  Motion is active by SensorBinaryReport

Using the UI, I set Motion Sensor Sensitivity to 'Very High' and then got a parameter report for #4:

dev:845 2021-07-21 03:34:34.871 pm debug ---CONFIGURATION REPORT V1--- MultiSensor6A (officeDesk) parameter 4 with a byte size of 1 is set to [5]
dev:845 2021-07-21 03:34:34.701 pm trace configurationGet command(s) (4) sent...

Small set of tests but they are all encouraging :smiley:

Is the speed improvement noticeable?

That is a good question - I updated to 1.14 a while ago but never really noticed. I've reduced the use of the MS-6's over time. Only have 2 left - one acts as a light detector and the other as a backup motion sensor to my main sensor (Iris V2 hacked for power) in the garage. It seems to work okay though.

Good news. Then I have a problem with my device I guess. Tomorrow I'll try on a different device.

Thank you.

Any idea why I do not get an answer from Get Parameter Report (Parameter number 4) ? I tried on 3 different devices.

Are you waking the device up after sending the Get Parameter Report command?

1 Like

How can I do that ?

Edited: OK found it in doc. Thank you I'll try.

Edited 2: Now it works, thank you !

I cannot send a Set Parameter using a Rule because I did not find a way to wake it up. Is there a way to wake up the device by coding something ?

Don't think that's normally possible right? It will only start listening when it is scheduled or something happens. Can you plug it in?

No I can't. I'd like the motion to stop during the day because it's draining the battery and I don't need it during the day.

Download the Hubitat app