Aeotec Home Energy Monitor 2 (gen 5)

Is anyone else using the aforementioned device? I have pretty conclusive evidence that it destroys my Z-Wave topology and wondered if anyone is using them successfully.

I've purchased 3, returned one but ultimately, all 3 eventually brought my Z-Wave network down. The moment, and I mean 'the moment' I take its power away, everything begins working again. Z-Wave logs in Hubitat support this in various ways.

This is not a ghost-related issue--I'm familiar with inclusion/exclusion/ghost devices and topology interference--this is an 'if it is powered on issue, everything else is eff'ed.' I have no ghost devices and have excluded (or forcibly removed ironically with the Aeotec USZ stick process) the power meters that I've powered off.

What I'm looking for here is testimony that anyone else has made them work... or not... 'cause I can't keep them stable. :frowning:

I've had one for a couple of years.
It's been reporting power every five seconds all that time.
I recall it was a pain getting the driver to work right.
Other than that, it's been solid.

1 Like

I have one as well. No issues using the ‘Aeotec Home Energy Monitor (Gen 5)’ driver

1 Like

I also have one of the Gen 5 and 2 of the earlier generations. They are on a hub that has barely no other Z-Wave on it, but they are working fine.

Thanks, all!

Well, I tried one more time and it worked for a day and then everything became hosed again. I powered it off et voila... guess it's just my particular setup, sigh.

I have one of the gen 5 HEMs as well, and a fairly small z-wave mesh. But haven’t noticed issues. I did change its parameters a while back to try to ensure it wasn’t flooding the mesh with measurable but meaningless attribute updates.

1 Like

These are just super chatty devices by nature. You can turn the reporting way down and that might help, but the way I solved it is the same way @Sebastien has.

I have two Gen 1 on a separate hub, reporting every second, and one Gen 1 reporting every 5min. There are no other Zwave or Zigbee devices on that hub. Everything works fine. Doesn’t interfere with any other apps that are on that hub.

1 Like

My guess is you have poor.connectivity and the chattyness is bringing network.down.

Put a device.or.good zwave extender next to it

Symptoms speak volumes and it all works with absolute immediacy without the meter in-play; deploy it; wait a day; it all breaks; unplug it there and then and everything is restored to normalcy within seconds. So no, I don't agree. The network is stable and comprises some 50 powered Z-Wave devices providing the needed coverage.

Have one as well. Works flawlessly. No issues at all.

1 Like

Yup, I get it--but I've tried 3 of them and the end result is the same every time. :man_shrugging:

I had one for a couple of years...(currently using iotawatt) and never had a problem with it.

Found that one--US sales discontinued sadly.

You can find one for sale on their forums sometimes.

1 Like

Hadn't thought of that--will take a look. :+1:


I'm gonna try it on my second hub... but it irks me that I have to go to these lenghs. That said, the rest of you have no probs so again = :thinking::man_shrugging:

Hub mesh is super easy. Worth the tiny effort to separate the chatty devices. I also use my second hub for apps I’m less comfortable having on the main hub for various reasons.


I am using this driver on my HEM V1. It is working ok except for 2 errors I would like to stop.
The battery error is moot for me since my HEM uses no battery.
How can I comment out some lines in the driver to stop these errors?

The watts and power reporting is fine. This is all I need anyway.

I use rhe built in driver and get no errors.

Which driver?