Aeotec Heavy Duty Smart Switch, Z-Wave Plus Home Security ON/OFF controller

Does anyone have the Aeotec Heavy Duty Smart Switch working? It pairs (securely) easily enough, but I couldn't find a device type that worked with it. I've got two of these things controlling a water heater and a water pump at a remote location with a slow unreliable Internet connection. Local control of these is essential.

Did you try porting the ST DTH across?

I’ve not. I was hoping someone else might have already done it, or is planning to do it. Although I was (years ago) a programmer, by trade, I’m new to this environment. My other challenge is that my Hubitat is functioning at a remote location. I don’t have ready access to either it, or the Aeotec Smart Switch device at my normal home. That said, maybe this is an excuse to get a second Hubitat :slight_smile:

Well, I did get a chance to port over the ST Aeon Secure Smart Energy Switch UK DTH and it seems to be working. I’ll have to do some additional testing to be sure.

1 Like

@btbauma did you get this working?

Yes, it appears to work just fine. I ported over the ST Aeon Secure Smart Energy Switch UK DTH and simply changed all of the physicalgraph strings to hubitat. I tweaked the delay between sending commands, however I don’t know if that tweak was really necessary. I have not had any problems.

@btbauma sorry to dig up a year old topic but is this the ZW078-A device? If so, do you mind sharing your ported driver?


I certainly can, although I'm using the Aeotec Smart Switch 6 built in driver and it seems to work just fine, including reporting energy use. When pairing this switch, Hubitat will not find a driver and just treat it as a "device", but you can then change the device type to the Smart Switch 6. Pairing for me required that the hub be pretty close to the Aeotec Heavy Duty Switch (a few feet). I did "port" two different ST drivers over by simply doing the minimal substitutions necessary and could post them if the built in driver doesn't work for you.

One problem that vexed me initially is that all three drivers worked most of the time, but not all of the time. Sometimes it would take a couple of tries to get the device to respond to on/off. I guessed that the problem might be that the device pairs securely by default, and Hubitat, before some particular firmware version would let that occur. Now Hubitat, by default, only pairs securely with locks, although that is configurable. So, I unpaired the switch, and then re-paired it insecurely, and it became completely reliable. I never bothered working with support to figure out why secure pairing wasn't reliable, as it wasn't that important to me. I suspect that Hubitat could formally support this Aeotec Heavy Duty Switch, just by forking a copy of their existing Smart Switch 6 driver, removing some of the code related to the LED on the Smart Switch 6, and adding the appropriate signature to recognize it.

1 Like

Thanks for the response, good to know it's working with the stock driver for the other Aeotec switches, makes sense that's a similar base with higher handling. Appreciate the response!

Where is this ported DTH please?
I am currently using Generic Z-Wave Relay for now.
This means the switch works but is not reporting energy/power usage.

I have found a ported Device Handler for the Heavy Duty Switch
name: "Aeon Labs Heavy Duty Smart Energy Switch", namespace: "peng1can", author: "peng1can"
but this only reports energy and I can seem to get the actual switch working

Have you tried the built in Aeotec Smart Switch 6 driver? That works for me, both reporting energy use and controlling the switch.

I can't get that built in Aeotec Smart Switch 6 driver to work for me. Either with the hub in secure only paring mode or just Locks/Garage Door secure mode. I'm in Ireland - so maybe the built-in one I'm using is for the US model. Could you share the DTH that you have up and running?

Many thanks, Simon


Sure, sorry for the delay, i was on holiday. Try this code snip-it. I just took a SmartThings DTH and made the minimal changes to port it to Hubitat.

Here is one I ported. If this doesn't work, I have another one as well.

I having trouble getting the Power to work on my Aerotec Heavy duty. I have use the Aeon Smart switch 6 and the Heavy Duty Switch driver but still having no luck getting the power to show up and working correctly? Thanks

Does it not work at all or just sometimes?

It work but not with the power so I when and reinstall a driver that I had and it working thanks.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.