Aeotec Gen 5 Energy Meter

For some reason my Aeotec Gen 5 Energy Meter will work perfectly with this driver:

But only for about 24-36 hours and then it stops responding. Refreshing or configuring the device does nothing. I have to exclude and reinclude it. I am getting the following error:

org.codehaus.groovy.runtime.typehandling.GroovyCastException: Cannot cast object '1' with class 'java.lang.Integer' to class 'java.util.List' on line 415 (setAssociations)

And I did post this on the thread for that driver, but I was curious what everyone else was using for this device because I have tried two different drivers and had issues with both.

use the one in hubitat package manager

I do not see anything related to aeotec energy meter drivers when I search the package manager for the terms "Aeotec" or "Energy"

What would be the name of the package?

Thanks

Hmm, thought it was in there. I'm using the one by Taylor Vierrether and it's been solid for mine. What security is it paired at? I use none. How often do you have your reporting set at? What firmware revision is it? How far away from your hub is it? What speed is it running at from it's current position?

Do you happen to have a link? When I Google his name I don't find anything. As for the questions:

What security is it paired at? Z-wave details shows S0 Security

How often do you have your reporting set at? Power was reporting every 5 seconds, I rose that to 15 this morning. Likewise energy was every 120 seconds, now it is 180. The 5 and 120 were the defaults. The 15/180 has worked so far, we'll see if it crashes around the 24-36 hour mark like it did last time.

What firmware revision is it? 1.35

How far away from your hub is it? About 30 feet, but it is only 15 feet from a repeater

What speed is it running at from it's current position? Shows 100kbps

i have the one from the thread. Re pair it with no security and see how it does. Last question, any ghosts?

I'm not sure what you mean by ghosts? And I'll have to figure out how to pair it with no security. I'll do some Googling

Personally I was never able to get mine to pair without security on my C-7 so I ended up using hub mesh and keeping it on my C-5.

look at your z-wave details page. you will see a column with in and out. there should be numbers for them. if it says in and out with no numbers then that's a ghost and it needs removed. a short press on pairing should pair at no security

I have 11 devices where In and Out are both blank. Not sure where these devices came from. How would I remove them since they don't show up on my device list?

If you go to the ZWave or Zigbee info pages from Settings, you can see all the devices stored in the radios. You can delete them from there. You can also attempt mesh repairs there if you move devices or hubs. Each device will have a "refresh / repair" button in the middle column unless the unit can't seem to communicate with the device, then a "remove" button will become available. You can do an exclude on ANY device, even one that isn't on your list, and in fact the best results I've had with migrating is doing an exclude on EVERY new device just before adding it to my hub. 1% failure rate so far (which is a hell of a lot better than ST ever was).

Yes, every single one of them need removed. This is why things are locking up. You have a ■■■■ ton of ghosts. Whenever you have a failed pairing, stop and check your z-wave table for ghosts. Now if you have problems removing them, if you know which devices failed initially when pairing, remove power to those devices, shut down your hub and unplug at the wall (not the hub) for 5 mins. Power back up and remove each one. If you do not see the remove button on the ghosts line, click the refresh button on that line several times until it shows. If you click remove a couple of times and nothing happens, wait.... You will get a pop up asking for forced removal. You may have to go through this several times.

Every ghost I try to remove just gives the error:

Failed node XX remove status: 0

I have no idea which device these are so I cannot do exclusion on them.

you don't do an inclusion. simply disconnect power to the devices, the follow my reboot instructions

Just to confirm my thinking because I don't know which devices caused the ghosts... my hub and router are on battery backup so I am going to do the following:

  1. Flip my main breaker (no power to entire house)
  2. Shut down the hub
  3. Unplug hub at the wall for 5 minutes
  4. Replug in the hub
  5. Remove the ghosts
  6. Turn the power back on

Is that the correct order of operations?

Powering down the hub for 30-45 seconds should be enough…. Looks like the right order.

I wouldn't say whole house, just those devices. When you're done removing the ghosts, download your latest backup to a pc, do a soft reset and re apply the backup you downloaded. This will ensure your database doesn't have any corruption

Download the Hubitat app