Aeotec Doorbell 6 tamper setting

I have just transferred my Aeotec Doorbell 6 from my A.N.Other system to Hubitat. In the previous system I had the tamper response disabled. I don't see the setting for that via the Hubitat interface, and so it's chiming whenever its touched or even if the light levels change suddenly. Can anyone advise please?

When you brought it over from your other system do you perform a factory reset of the device to bring everything back to baseline first? I don't see the tamper capability in the built-in driver for the Aeotec Doorbell 6. Are you using a user driver? If it did use that capability, you would see the tamper attribute somewhere in the device page.

I don't see it listed in the parent or child devices. So, I suspect that the settings you have for it got screwed up in some way when you brought it over from your other system.

No I didn't factory reset it, just the exclude and include. I am using the built-in Hubitat driver. Perhaps I need to look for (or write - if or when I learn how) another driver. Actually now I come to think of it, it might have got lost at an earlier time, as I changed drivers several times when setting it up on ST initially. Would be good to be able to configure it now, though.

The tamper alert won't be able to be received by hubitat though, unless you build your own driver. To use the built in driver, I would exclude the device, factory reset it, then include it again. Then you shouldn't have a problem.

I am using the built in driver. I don't expect tampering events to be receivable as messages by hubitat but it would have been nice to have the setting exposed and configurable. Are we allowed access to the code for the built-in drivers? It would be easier to add to some existing code than work out how to do it from scratch.

Hubitat has some example drivers in their github you can make use of. But the built-in drivers are, almost entirely, closed-source.


The Hubitat handler uses the tamper endpoint for playing chimes so the tamper feature should be permanently disabled in Hubitat.

Your issue might have something to do with it not being factory reset, but clicking the configure button should solve that, at least it should with the C4 and C5 hub...

1 Like

I've got C7 :smiley: What I have found is that I can make the tamper silent if I turn down the volume for the chime, but that also makes the chime silent which isn't really what I wanted. Right I'll use the Siren child rather than the parent for when I actually want a sound. I'll test it later.

If you enable debug logging and see any messages like "unable to...", "unhandled...", or "ignored..." then the device probably isn't supported by the C7 and you should post the logging results and tag someone from Hubitat.

The device also supports volume control so you could make your rule set the volume before playing the sound and set it back afterwards as a temporary solution, but you'll need to leave a 1-2 second delay between the volume and play commands...

Well I've set the siren to vol=50 and sound #6, and the chime (parent) to 10 and a quick ding-dong just so I know it's doing something. Since I am using it as an intruder alert only and don't need both types of sounds this might be perfect. It's up two flights of stairs and I am not testing it till I have to go up for something else - in this hot weather :frowning:

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.