Aeotec aerQ - round 2

I've been pretty happy with the Sonoff SNZB-02 as a humidity senor for my bath fan, but the 5-minute reporting interval wasn't exactly ideal.

Prior to the Sonoff, I had tried the Aeotec aerQ, and that was really bad (15-minute reporting interval), but I recently noticed that Aeotec put out a new version of the aerQ... The original was model "ZWA009" and the latest is model "ZWA039".

I installed the 039 model and I used the Basic Z-wave Tool driver to tweak a few of its parameters so that I get a report anytime humidity changes by 3%, and I think this thing may be a winner...

Early experiments so far are encouraging -- I disabled temp-change reporting (not useful to me), and I have been getting solid reports for 3% humidity changes during a shower sequence. I changed the periodic reporting to 30 minutes, and I'll likely bump that out to an hour or two (or longer) if I keep seeing good results with the 3% humidity-change reports.

The thing to watch now is battery life - we'll see how that goes in the upcoming weeks & beyond.

I'm anxious to see how the soon-to-be-released Zooz temp/hum sensor stacks up, but so far, this latest model of the aerQ is a much-improved successor to the original model.

1 Like

Thanks for the findings! I had no idea they apparently silently replaced the ZWA009 with the ZWA039, but apparently they did, and the addition of a few parameters to control reporting is one of the differences I've been able to find (from a third party:; can't find anything from Aeon directly). Hopefully they can add the reporting parameters to the original version via firmware update, or maybe such a thing already exists...obviously won't do anything for the hardware tweaks, but would be better than nothing. And now I want to check mine to see which version I got... :slight_smile:

I have a few of the Sonoff temperature/humidity sensors and they've been fine for me, but I don't really care about the frequency of readings, so I'm not as picky with those, and unlike the Aeon, they're cheap enough that I don't care. Hopefully the Zooz product will be reasonably priced (usually are!) and configurable (and if not, they're good at listening to feedback).

1 Like

Good add'l info - thanks!

If you pop the case open, the model number (009 or 039) will be on the interior label.

There is a f/w update available to the 009 model that would be a nice improvement but doesn't quite bring full parity to the 039 model (as far as I can tell).

I still had my original 009 model, but I couldn't get that update to work (even after correcting the errant space in the file name). I've successfully updated other Aeotec devices, so I don't think the failure was user error but who knows. I decided the 039 was worth a try, and so far so good.

I too am eager to see what the Zooz offering will bring to the table - it's certainly nice to see more capable options arrive for this type of device!

I am going to see if i can get that new firmware loaded. Looks like the file format may be right which has been a problem with Aeotec firmware in the past.

Captain's log - day 3:

The new model also may be plagued by some battery-reporting wonkiness that has been mentioned here in the community about the original model.

Was showing "0" battery in device details page / dashboard tile when I checked this morning, but when I hit the device's own action button, it all updated to "90".

I'll keep an eye on this - I've feared that battery stuff (reporting issues or just burning thru too fast) would end up dooming this device for me, so we'll see.

@hydro311 do you have any updates with the aerQ to share ?

I’m trying to decide whether to get the aerQ or wait for the Multisensor 7 to be released locally…

Sadly, no improvement to the battery-reporting issue - it still drops back to "0" w/in ~24 hours of pressing the button on the front of the device. But at least that physical button press will give a battery report - I suppose that's better than nothing at all.

Otherwise, the 039 aerQ is pretty great - if they would fix the battery-reporting issue, I'd use it as my primary humidity detector for my bath fan (right now, I'm still using my zigbee Sonoff as primary). I'm hoping Zooz releases their humidity sensor soon - I'm curious to see how that stacks up in this corner of the sensor arena!

1 Like


Is it just a reporting issue, or is it actually burning through batteries ?

Just a reporting issue -- it's not chewing thru batteries at an unusual rate (as far as I can tell). I've only had the thing for a few weeks, but the battery rate/performance itself seems to be fine overall with respect to a device like this.

1 Like

Been trying to read and change parameters on aerQ with the Basic Z-wave Tool driver, but don't get anywhere. When reading the parameters, log says "configurationGet command(s) sent..." and that's about it. When I try to set a particular parameter, nothing shows up in the log. Any ideas? Thanks

It's a battery device, so you have to hit Configure after you send the parameter -- that'll wake it up to catch it.

For the record, I gave up on the aerQ -- in my experience, both the ZWA009 and ZWA029 models continue to have maddening battery issues even with the latest firmwares, but perhaps you'll have a happier experience with them.

There is a new firmware version 2.02 for the ZWA039 Aerq that "resolves issue where battery reports 0% when receiving Battery Get commands from the controller. " I uploaded this new firmware to my Aerq and it seems to work as advertised. Access the update here Update ZWA039 aerQ Sensor V2.02 : Aeotec Help Desk


The firmware update 2.02 worked for me also. I was able to update using the Device Firmware Update built-in app. Right after the update the battery level read 1%. I put in a new battery. It is a CR 2477 that I got from Amazon. The battery level has now been 100% for a couple of days. I will keep an eye on it to see how long the new battery will last. I did disable the periodic reporting. This may help the battery life.

Props to Aeotec for getting the fix in finally. Now I at least know I have a viable option in my parts box if my ZSE44 goes south.

I'll stick with my ZSE44 for now since it's up-&-running and doing everything I want in terms of reporting.

Plus, I gotta say the ZSE44 is wayyy easier than the aerQ to open up for battery changes -- that may sound silly, but little things like that go a long way. Perhaps my aerQ is just built oddly tight, but man, that thing is rough to open.


How are you finding the battery life so far with the ZSE44 ?

The Zooz ZSE40 appears to use a cheaper battery (CR123A) than the aerQ (CR2477), which is also a plus.

It also seems a better deal than the aerQ as you get motion sensing as well - perfect for a bathroom to control fans and lights

Aeotec's equivalent (Multisensor 7) is almost double the price of a Zooz ZSE40 in my market; the main benefit of the Aeotec MS that I can see is that you can plug it into AC as an alternative to batteries...

Battery life is great so far, but I'm pretty light on what I ask of it -- I use it for detecting shower humidity, so I've minimized any temp reporting as much as possible and put long windows in for any routine reports. I have it trigger at a 5% humidity change.

Mine's still showing 100%, and IIRC, it updates batt status at 10% intervals.

In case you get one, be prepared to see the battery plummet if you mess around with parameters (i.e. Basic Z-Wave Tool), but it will go back up to normal levels within a day or so. Mine went down to 30 (maybe even 20) but bounced back up around a day later.

Overall, I'm pleased with the ZSE44. I just noticed NYCE sensors are back in stock on Amazon, so I'm going to try one of those out too... I'm not much interested in using its motion, but I'm curious how the humidity reporting will compare to the ZSE44.

to anyone searching, that link is dead. Googling the file name ZWA039_AerQ Sensor_US_V2.02.gbl found me this

I just spent half of the day to get the 2.03 firmware updated from the delivered 2.01 on 3 of these. I thought I was going to get away without touching them until day 3 presented "0" battery. Each one acted different. I had to reboot the hub between each one as well as remove, factory reset, include, and pray. Several times I would get to 80-95% and lock or finish file transfer and the sensor locks or sleeps with no recovery. Burnt through two coin cells. I am actually blessed I did not brick any.

Next time, I will use the stick on a Windows box/Silabs..... did not have a Windows box handy.

BTW, Aerq cases are impossible to get apart without some mauling of the plastic.