Aeon Labs HEM won't work for me

On my C4 hub, platform I have installed two separate Aeon Labs HEM DSB09104-ZWUS,

They installed easily, but I simply cannot get them to report energy usage. I have used three drivers,
(1) Aeon HEM, (2) Aeon HEMv2+, (3) Aeon Hem Gen5. No joy.

Have any of you folks had luck with these energy monitors. I see posts saying they are a loser and others say they work for them. If you have one working, what is the secret to success?

I have the Hem Rev2, I think, it’s pretty old. I am using the driver you list as #3. I installed it on my C7 hub probably 2 to 2 1/2 years ago. Didn’t do anything special.

I bought the HEM originally with my Iris system probably 8 or 9 years ago now. It ran fine there. I moved to SmartThings when Iris was shutdown. Then to HE. It has worked well on all three platforms.

1 Like

I have the V1 version (not zwave plus, very old) connected to a C5 using the "Aeon Home Energy Meter" driver and it's been working for about 2½ years monitoring my freezer.

I get an occasional error in the logs account some math issue or something but its a rare error and doesn't seem to effect anything.

I didn't do anything special. Just paired it to the hub. It's been so long I can't remember if I had to select the correct driver or if it auto selected it for me.

1 Like

Thanks for the replIes fellows. I'm going to install on my c7 and see if that works any better.

1 Like

I ended up getting rid of my HEM Gen5 and getting an Iotawatt. I can't tell you how much happier I've been... Built in graphs too!


Probably good advice. I'm going to put the cover back on the electric panel and move on to other things. These are probably the only HA devices I bought that just don't work for me. I guess you can't win them all :grinning:

My Gen5 worked for me but wasn't enough.

1 Like

I have three of these. They worked on my C4 and they work on my C7. I use this driver, but under the current hub version, I only get individual clamp readings, not combined. There was an older version of the hub platform where everything worked. I cannot remember what version, but I probably commented on it here at sometime in the past.

Currently I'm simply using them to get individual clamp readings for specific appliances in our home, but the only one that I'm actively using is my dishwasher for my dishes clean/dirty rule. Most of our appliances have the notifications we need, everything is on the same floor now (so laundry reminders barely make sense) and our lives are very different now than they were before COVID and when we lived in Toronto.

For whole house and over all tracking I'm using Sense. Tried it in the past and returned it. However, while it wasn't that accurate before, I decided to give it another try and it's working great now. I'm even able to use some of the devices it's found with Home Assistant and Home Assistant Device Bridge for notifications. Probably don't really need the Aeon HEMs, but the local aspect is a nice to have.


That was something I noticed when trying these out. Only one of the current transformers would be reflected in the power. And on at least one of the HEMs, with a 75 watt bulb as a test load, one CT would say it was 30 watts and the other 68. I'm giving up as I didn't have a big need for these anyway - just cheap fun I thought. Thanks for all the comments.

You definitely should get a reading from both clamps. One thing you have to remember is that they need to be over one lead, not both. So for monitoring a single circuit you’re only going to use one clamp. For monitoring the entire house one is on half of the branch and the other is on the other half of the two incoming main leads.

These devices are inexpensive as you note and they can tell you whether something is on or off. So they’re great for putting on a single branch circuit. Also remember that if readings are strange, reverse the clamp 180°. It does matter which way they are on to get accurate readings. They are chatty so I have mine on a separate hub and then I use hub mesh to bring the readings back into the main hub. Sounds like you also have two hubs and that is an ideal way to set it up. Personally I would use the C4 and run an old version on it if I needed the combined power reading. Otherwise I would just run the current platform version and just use the readings from individual clamps for appliances.

1 Like

Thought you might be interested. I have been holding off updating HA to 2022.7.x until I had a chance to backup the microSD just in case. Finally got around to it last night and since it all went fine, I decided to add Z-Wave.js, and try one of my Aeon v1 HEMs on it. This is something I've also been putting off since it previously seemed it would be complex. Maybe it previously was difficult, but my experience was plug and play. I had two HUSBZB-1 sticks available from my C3 (dead Ethernet) and my C4 (retired). Running HA Supervisor, this was very easy to setup. Just install and point to the proper port on the HUSBZB-1 stick in the UI.

Today I added one of my HEMs and it reports all except for two power readings, which I don't really understand why they don't update, but don't actually care personally. I was then able to use Home Assistant Device Bridge and bring in Total Watts, Clamp 1 Watts, Clamp 2 Watts, and Total kWh consumed (my custom labels for them) into Hubitat. Yet again another great use for HA with the community HADB driver/app. Not only does it resolve incompatible Zigbee issues, it resolves some Z-Wave compatibility issues too! Love it.


Your posts drove me to make one last effort. See attached image - it seems to be working! I added another line powered Zwave device to act as a repeater and perhaps that helped also. Anyway - thanks to all you posters. Like my daughter always said - man never fails, he only quits trying :+1:


Yep, individual but no total watts. That's what I get too from the latest platform build. Glad you got what you needed.

Those v1 HEMs are tricky. I've had good success with the following procedure which I'll post here in case someone else needs help.

  1. Put your hub in exclusion mode (do this from the New Device section on HE and you won't have to watch the logs to see an excluded message).
  2. Press the button once under the HEM battery cover. Don't hold it, and just press once and release. If it doesn't exclude immediately and the light on the HEM is solid, press it briefly again until you see the excluded message on the hub.
  3. Unplug the HEM for 30 seconds, no less.
  4. Hold in the button under the battery cover keep it held in while you plug the power into the HEM again. The light will flash rapidly a few times then return to a slow flash. (This factory resets it).
  5. Again unplug the HEM for 30 seconds, no less.
  6. Put your hub into Inclusion mode and then plug in the HEM power.
  7. Press the button once under the HEM battery cover. Don't hold it, and just press once and release. If it doesn't include immediately and the light on the HEM still flashing, press it briefly again and wait for the included message on the hub. Give the hub time to complete the configuration. The light on the HEM v1 will be solid when it's joined to a controller.
  8. It should be showing the readings on your hub. Keep in mind that the drivers often default to 60 second update times or more on some hub/driver combinations. If it's not reporting, unplug it for 30 seconds and then plug it in again. Do not press the button again.