'Aeon HEM V1 Laundry Driver' is NOW working on Hubitat

Unfortunately, the operating wattage range of my washer is so low, it results in frequent fluctuations between ON and OFF during a cycle and the changes you made could not compensate for this. I was able to finally resolve the issue by modifying the code to add a button 3 push when the washer is ON. I'm using this to cancel a rule actions if the washer has not stopped for 2 minutes, thus preventing false notifications.

I had to create two virtual switches, two RM triggers and one RM rule to accomplish what I needed. Maybe there's an easier way, but I couldn't figure it out.

How it works:
When the washer starts, the Aeon HEM pushes button 3. This turns on the virtual switches "Washer is running" and "Washer is done". When the washer pauses during the cycle and creates an OFF status, the rule "Send Washer Notification" becomes [TRUE] and begins a two minute countdown before it turns OFF the "Washer is done" virtual switch. If, before the two minute countdown has completed, the washer cycles ON, and therefore pushes button 3 again, then the rule becomes [FALSE] and the "Washer is done" virtual switch is turned ON, thus cancelling the countdown to OFF.

When the washer finally no longer cycles ON in a two minute period, then the virtual switch "Washer is done" turns OFF. This triggers an IFTTT notification that "The Washer has Finished".

Here's the modified code, and my RM triggers/rule if anyone finds it helpful.


[Edit] I've done a second adaptation to @ogiewon 's original port of @mike.maxwell 's Aeon HEM V1 Laundry DTH, this time adding a button 4 push to indicate the dryer is running. This can now be used in conjunction with RM and Google Assistant Relay to check the status (running or finished) of a washer and dryer.
Using IFTTT integration, you can ask Google Assistant or a Google Home for the status of your laundry and get a spoken response based on what is currently running or if nothing is running.

Please note: I have modified the original port of the code, because Dan's second revision to the code did not work for my washer and actually caused a greater number of false alarms. Your experience may be completely different. I have a very difficult washer to determine the running, versus off amperage.

1 Like

Glad you found a workaround. I guess I am lucky that my washer and dryer are 'well behaved' when it comes to power usage.

One thought... I wonder if you could have implemented all of the logic within the Driver code itself? Instead of immediately sending the button pushed event for washer is done, you could schedule an function to run in two minutes. If another off to on transition occurs, you could unschedule the timer. Essentially, implement the delay with cancel inside the driver. It would definitely be cleaner. A user preference could be added for 'How long OFF before sending event'. Thoughts?

1 Like

That’s a great idea, but not one I have the skill to accomplish. I was happy just to have figured out how to modify the existing code enough to accomplish a third button that does what I expected! :grimacing:

@ogiewon I have the same problem that @SmartHomePrimer has and would love to see your idea come to life? It's beyond my skill level also.

I'll take a look at adding some more intelligence to the driver to help reduce false/duplicate notifications. Hopefully I'll find some time this weekend.

1 Like

@oglewon I know that you very busy. Did you ever look at changing this to add more intelligence to the driver? Thanks for all your hard work.

Hopefully, with the long Holiday Weekend, I will find some time to get back to looking at this.

Sorry for the delay, but life always seems to get in the way! :wink:

Since I put those three rules into effect, the false “done” indications on the washer are gone

I am interested in doing this as well. Do you guys know if the newer version of the energy meter will work, or do I need to get a V1?

Looks like there is a newer Aeotec Home Energy Meter Gen5 available on amazon. I believe the V1 is Zwave, not Zwave plus correct?

Could be. Mine is v1 and I don’t find the Z-Wave Plus logo on it or anywhere, in the box or instructions. If you’re concerned about compatibility, I only bought mine a few months ago on eBay. Probably still available.

The device driver posted in this thread is specifically for a 1st gen Aeotec HEM, as far as I know.

@SmartHomePrimer could you share what you did cause I'm still getting false reading? Thanks

This post. You need the code I modified to give a button 3

You'll need to play with the running wattage of your washer to fine tune. I just raised it a watt at a time (for my washer anyway) until I hit the right value. Took some weeks to find it.

@leeonestop I have updated the driver to add a required parameter which allows you to determine how many seconds the washer/dryer must be below the wattage threshold before the button pushed events are triggered.

Please note that the Aeon HEM v1 transmits data every 30 seconds. I would recommend that you use a 'Debounce Time" of at least 45 seconds so that it takes at least two updates in a row, below the wattage threshold, before any messages will be sent. You can make this much larger if desired. If the wattage jumps back up above the threshold during this time period, the delay is reset.

Please give this version a try and let me know if it resolves the false positives/multiples events you've been seeing.


1 Like

@oglewon thanks for the code. I will do laundry tomorrow and will try the code. Thanks for all you have done for us in the Smart Things and now the Hubitat community. Thanks so much.


@ogiewon I did laundry yesterday and this morning and this is not working for me? I was getting messages from pushover and now nothing? Is there something that I need to redo? I downloaded and install you new code and hit the configure in the app and I'm also using the pushover app? Any help would be appreciated.

Did you enter a 'Debounce delay time' and click Save?

@ogiewon yes I did 45 just like yours? Maybe something on my end I will restart the Aeon Lab V1 HEM and see if that help. Thanks

You didn't remove the Aeon device from Hubitat, did you? You should have simply updated the Driver groovy code, entered in the time delay, and clicked save.

I have 2 Hubitat hubs, and two Aeon HEM's. They are both working fine using this new version.

I am not sure why it wouldn't work for you.

@ogiewon I just updated the code and save just like you said. I did unplug and restart the Aeon device but in the area of washer state it shows off but is running at the moment? Not quite sure what is happening either.