Advanced and generic zigbee rgbw drivers not working


I'm trying to set up my new Gledopto rgb+cct 1ID controller through hubitat, but it seems like the drivers are not working... whites do not work at all and colors works but not really ...

PS : I had Gledopto rgbw controllers before and decided to upgrade everything to rgb+cct controllers after moving out for better whites but it seems like the drivers are broken.

Am i the only one ? Yes i clicked on the "configure" button


Sorry if this is an obvious question, but have you verified that the strip is hooked up correctly? And I assume it is a 6-wire strip like the controller expects (RGB, one each; plus cool white, warm white, and V+ or however your strips label that)? Not trying to insult your skills, but I can say that I had a loose connection in one once, and all my colors were off until I figured out what I did. :slight_smile: And, of course, your whites will be off if your controller has separate warm and cool channels but your strip has only one (or none at all), which I only bring up since you switched controllers but it's not clear what strips you were using before or now.

Regardless, I've only used mine paired with a Hue Bridge network, not directly to Hubitat, so there could be issues there too. (I didn't have any issues on Hue except that they are so much slower to respond than Hue bulbs or strips--even worse for the 2-ID models where one "channel" or the other always seemed to miss a command--and I eventually replaced them both out of frustration, but that's another story...)

Thank you for your answer bertabcd1234.

Yes my strip is hooked up correctly, it is actually two strips, one rgb and one cct.
I tried different strips and controllers to test out, seems like the driver doesn't do what is supposed to do unfortunately... I don't have a HUE bridge.


possibly the driver doesn't do what this device needs it to do, so which driver are you using now, and which driver were using with the RGB controller?

The advanced drivers are probably not going to work with these controllers.

I was using the generic zigbee rgbw driver with a 4in1 strip, it was working fine before. I tried yesterday, it is not working anymore... generic and advanced drivers are flawed with both types of controllers

nothing's changed in these drivers in 2.2.9

For me, It was working a few months ago...