Adding Wifi dongle with OTG cable difficulties

Trying to connect a TP-Link TL-WN823N v1 wifi adapter via an OTG cable and I'm not having success. I've followed online instructions, added driver and set SSID name and pw, rebooted hub but not connecting. I've also tried 2 different OTG cables, no joy.
The adapter works when plugged into my laptop. I also notice a green blinking LED when device is plugged in laptop that I'm not seeing when on the hub.
I'm sure it's something simple but damned if I can figure it out.

Did you install the wifi drivers first?

Yes. The hub said it was successful.

I didn't see a way to uninstall driver and start over. In case something went sideways when the driver installed.

Assume you disconnected the Ethernet cable after confirming the reboot?

Yep. Even tried waiting to plug in adapter until after hub booted. The wired connection is still set as DHCP ecause I had set a reservation for the wired MAC in my router. Not sure if that has something to do with it.
But to answer your question, yes, the wired connection was unpkugged when it rebooted.

The dongle will get an IP that is different than the wired connection, I take it that youโ€™re not seeing new device on your router, or a different IP at http://findmyhub.hubitat.com/

That's correct. It isn't connecting to the router. I never see the wifi MAC on my router.

Also, haven't reserved the wifi MAC on the router yet.

About out of ideas, time to ask @gopher.ny what am I forgetting?

Is there anywhere in the logs where I can see issues with it or verify user/pw info?

Actually, discovered this in the logs.

I believe the adapter listed on the linked Amazon page (and that the driver is built for) is a v2.
This is the direct link to the produc image in the listing, which shows FCC id TE7WN823NV2.

Give it a reboot... something may be stuck. Can't say what exactly without looking at the logs. If you want me to check the logs, please PM me the hub id.

I ordered the long range adapter and we'll see what happens. Guess it may be that the v1 adapter I tried isn't compatible. I actually had that one already.
I did reboot several times with the same result. Is there a way to do a complete factory reset? I don't have a huge amount of devices setup yet.
Otherwise, I'll wait for the other adapter and give it a go. Let you know what happens.

Yes. Do a Soft Reset without restoring a previous database, and then reset the z-wave and zigbee radios.

Download the Hubitat app