Adding sensors to Alexa


I am pretty new to this and I just got my C8 few days ago and I am learning a lot in the process of setting it up.

I have recently bought 2 motion sensors (ThirdReality) and 2 temp/humidity sensors (Sonoff SNZB-02D), They were paired successfully to the C8 and I have tested few basic rules and they seem to be working well.
The motion sensors were added as generic Zigbee Motion with no temp, not sure if there was specific driver for them(at least I couldn't find one) while the Sonoffs were added with a dedicated driver.
I tried then to expose them to the Echo Skill but I am not having any luck
They are in the devices list in the Echo skill but Alexa seems to be ignoring them and doesn't know they exist.

Is there something I am missing or simply they are not compatible and won't work with Alexa through Hubitat?

Thank you

Which devices are not showing up in the Alexa Skill? The motion sensors should work without any trouble. Temperature/Humidity sensors??? Not supported unless the temp sensor is part of a motion or contact sensor.

Take a look at the Hubitat Documentation for the Alexa Skill.

1 Like

Thank you for answering.

It sucks the temp sensor cannot be added but I will survive :grinning:

As far as the motion sensor it does not get discovered by Alexa. I have followed this guide though as a workaround and seems to be working. Steps 6 onwards that covered the virtual switches
Alexa and Hubitat - :bellhop_bell: Get Help / Integrations - Hubitat

In order for the Alexa skill to see a motion sensor, I believe its hubitat “device” details page must properly show the “motion” attribute as either “active” or “inactive”. If that attribute does not show up on the motion sensor’s device details page, the Alexa skill will not “see” the device. Just a guess…

The sensor does have the active inactive state listed
I thought I got the workaround going but sadly no go. With or without the Virtual SW it does not get detected.

My process for adding the Alexa Skill to Hubitat is as follows:

  1. remove the Amazon Echo Skill app from your Hubitat hub (if installed already)
  2. go into the Alexa mobile app on your phone/tablet and Disable the hubitat Skill
  3. go through your list of smart home devices in the Alexa mobile app and make sure to delete/remove any lingering devices that might have been associated with the Hubitat skill

Now that we have a clean slate…

  1. open the Alexa mobile phone app, and Enable the Hubitat Skill
  2. this should request that you log into your Hubitat cloud account and select your Hubitat hub.
  3. after doing so, the Amazon Echo Skill app with be automagically installed on your Hubitat hub
  4. select the devices you’d like to expose to Alexa and make sure to click DONE at the bottom of the page to properly save the settings

Your devices should now be available in the Alexa mobile phone app.

1 Like

That was my thought too, Will give it a try

Thank you again for pitching in. Very much appreciated !!

1 Like

When one goes dow the rabbit hole gotta be prepared :rofl:

Followed the steps above and it resulted in:

1.Couldn't link Alexa skill again. Kept getting "Link unsuccessful"
2.Browsed a couple of similar topics and decided to reboot/shut down the hub in order to clear it
2.Upon powering back on the hub decided to give me "Hub shutdown please wait for the confirmation". right after "Initializing Zwave Zigbee...." Twice!
3.Third time is a charm and the hub rebooted successfully
4.Attempted to link the skill again and it eventually went through,

I am glad to report that now Alexa dicovered all the devices including the temp/humidity sensor yet it reads just the temp and it spits it out in F not C. No clue where I can change that but need to dig a bit.

All in all a great success. Thank you. @ogiewon

1 Like

Go into hub details.

Thank you for pointing that out.

I have combed through all my settings and I found the culprit
The hub was set to C, each individual device is in C, the Amazon account and the Echo devices were all in C YET... the actual app (Alexa) needed a specific location and to be told to show things in C.
The weird thing was that the majority of my devices were all showing C but not the ones I have imported from the hub. Very strange,
It seems to be behaving now :grinning:

1 Like

F is still better...

(Running away....)

1 Like

Don't run yet :rofl:

In Canada is not uncommon for people to use liberally a mix of C and F. Some use F for their ovens or ...whatever while the weather is being reported and read in C .I personally prefer the C for my indoor/outdoor temp while I can still grasp the F for other things