Adding Matter devices to Google Home app - anyone else having serious issues?

This is not specifically an HE issue, but thought I'd share - interested if other Goggle Home app users are running into this when adding Matter devices to the GH app. If it's always this wonky/difficult we're really going to need to warn people when they get started adding Matter devices via the GH app.

My results are from adding four Tapo Matter Wi-Fi plugs - P125M - to the Google Home app.

First main issue: I always have to reboot my phone to successfully add these devices to Google Home.

If I do not reboot my phone, the GH app Matter add device process it always fails here:

Failure message:
image

I've tried the following on the GH app (I'm running the beta):

  • Clear GH app cache
  • Force Stop GH app and restart

Also tried:

  • Change back and forth between networks on my phone
  • Use a 2.4GHz-only network
  • My network is Ubiquiti ER12 + U6-LR and NanoHD APs

On the plugs:

  • I've reset them many, many times (both 5s and 15-20s long press on power button) and it doesn't help.
  • Also unplugged and re-plugged them multiple times, no help

Second issue - occurs during what turns out to be a successful join:

I end up stuck on this screen in GH app...I can leave it for 10m or more and it never moves on past this screen:

I back out of this screen, which brings up a confirmation which I acknowledge:

Yet I find when I go back to the Devices tab in the GH app the device has in fact been successfully added (Mini Smart Wi-Fi Plug) in the "In your home" section. The plug is fully functional via GH and I can generate a code from the GH app to add it to HE where it works fine.

Are any of you using the GH app to add Matter devices, seeing this or something similar when adding new Matter devices?

1 Like

I haven't had any issues at all using Google Home. I'm on the GH beta version though (3.10.1.6). So far I've linked 6 of these Linkind Matter Smart Plugs. They are running all of my indoor Christmas stuff.

I also connected two plugs using Alexa and have to say I like the GH way of doing it much better.

https://www.amazon.com/Linkind-SmartThings-Automation-Control-Schedule/dp/B0C371HB66

2 Likes

I've had similar problems with GH primarily when adding a Matter device that has already been commissioned on another controller, but commissioning a device the first time with GH is not (always) smooth sailing either.

1 Like

It's borked. I almost posted about this, but since it involved a Lorex NVR, not HE, I said meh. Anyway I spent 4+ hours on the phone with Lorex & Google with zero resolution. Then a week later, I tried again and after about 8 attempts failures it finally worked. But then the next day the device fell off. I think Matter has a long ways to go IMHO. And as far as I can tell there is no "re-pair" once the buggy POS falls off, you have to start over, as I don't see any reconnect feature.
When it worked for a few hours, I could activate the lights & sirens on all my cameras at once, with a GH button. I'm confident the minute Google figures out how to monetize the Matter data information collection, it'll start working 101%.

I just grabbed 2 Tapo RGBW A19's, at 1100 lumen. I wonder how much time I'll waste on figuring out those.

1 Like

I am expecting that Hubitat integration will become "guilty by association" so the more users share their experience, the better others will understand the current challenges.

2 Likes

I guess I'm one of the lucky ones? Our house is currently running four Kasa, one Tapo, and a Third Reality Nightlight via Matter. I've been able to add them all to Google Home, HomeKit, and Hubitat without any problems. It doesn't matter if I start with Apple Home or Google Home. I'm also using an iPhone and am in the Google Home Beta.

Planning to add a few more of the night lights, and then, start testing Thread devices.

2 Likes

Same - I'll add that to the OP.

Also forgot to note that I repeatedly reset each of the plugs to no avail...

Yeah, exactly, past experience does seem to say that will happen...

And as of this morning (added three of the plugs last night) one of them that I hadn't linked to my C8 yet is failing to allow the link process in GH app...I get some combination of the three screens below when I try to start the process...[sigh]

Going to have to start over - remove the plug and re-pair it to GH, etc.



2023-12-07 09_01_21-Main Chrome

I had a horrible time getting a Govee M1 Matter strip to connect.

My Google Home Matter devices ate the Mini speakers.

ITt would start the add but then just repeatedly say it couldn't connect. To make it work i found i had to do the following.

  1. Do a factory reset to the matter device.
  2. Reboot the google mini speakers
  3. Clear cache of the Google Home app on my phone.
  4. Reboot the phone.
  5. Power cycle the Govee strip ( govee's process to start pairing on the device.)
  6. Then wait a few min before attempting to do the add.

The Govee devices goes into pairing mode when power is applied and it isn't already linked. It also has the code to connect. So i just pair it directly to Hubitat and that has been very reliable. This requires.

  1. Factory reset the device. To get clean starting point.
  2. Add to govee app and connect to wifi
  3. Pair it to Hubitat with the code provided.

Only time it failed or gave me issue connecting to HE was when i had a weird event were it was paired and suddenly disappeared from the HE. It wouldn't pair for nothing. I had to reset the Matter integration on the hub and it quickly worked the next attempt.

Wow, I'm feeling a little less sorry for myself now...what a process!

If I wasn't testing for the Matter beta all the Matter devices I have would be on their way back to Amazon...so not worth the trouble and complexity that Matter is causing, at least in my case.

Just to put my name in the hat as another battling with GH and matter. Got a Nuki lock and GH just gets stuck on "connecting device to google home". I really don't want to have to factory reset as I think I will lose all my fingerprint and pin data.

Glad I found this thread, though I seem to have the opposite issue. I recently got a Matter version of the Smartwings roller shades. It appears that I was able to connect it through Google Home (v3.11.1.10), but it shows 'Offline' in the device list and cannot be controlled in Google Home. HOWEVER, I was still able to generate a code, add it to Hubitat, and control it just fine through Hubitat.

It still shows Offline and can't be controlled in Google Home. When I click on the device in Google Home, I get an error: "Can't see Bedroom Shade on this Wi-Fi network. Check that it's online and that your phone or tablet is connected to the same Wi-Fi network."