Adding Kwikset 620 - Device reads "Discover"

Your referring to the lock itself as the ghost, right?

Correct, the one with the discover on it's line. Follow the instructions above.

Got the remove to work. Shut down hub. Got my long cable out and moved hub to lock. Did a factory reset on lock. Powered back up. But now the lock itself doesn't seem to want to go into pairing mode. Not sure what is going on there. Reset the lock again, still wouldn't go into pairing.

Have to wait till later to try again as I got to leave for awhile.

Had one good stroke of luck in the middle of all that. I have my hub on a UPS. When I moved it it was no longer on the UPS. About 30 seconds after I moved it back we had a power outage. Glad I got it moved back first.

1 Like

Called Kwikset. They had me run through some trouble shooting stuff. No luck. So they are sending me another one. No questions asked. Quite pleased with the customer service.


Finally got my new lock. Still had issues trying to get it to pair. Tried several times, no luck. Finally decided to try the smart start. Wow, that finally worked. Gonna keep my hands off it now..:slight_smile:


If you have a line with discover on it, you created a ghost and that needs to be removed or it will reek havoc with your mesh