Actually factory reset devices

I am aware that there are topics around factory reset already, however I am confused by the information provided in these threads. I have both a C5 and C7 hub. Both of which I want to FULLY factory reset. I want to start my entire configuration from scratch and do not want to keep any radio or device information. All I could find is how to "soft" reset which does not do what I want.
Based on information in other threads about this topic I should reach out to support about this. I don't see a messaging function, hence I created this thread.

The difference between the recipe I'm about to type and "Full Reset" is that you retain the registration. Since you want to keep the hub, then this is "better":

Settings: ZWave Details:
Screenshot 2023-03-18 at 9.50.42 AM

Settings: Zigbee Details:
Screenshot 2023-03-18 at 9.51.08 AM

Then Soft Reset.

the result will be a hub that you can start anew.

Besides the above, it's worth noting that you can also find this question answered in the Soft Reset docs, for anyone who may find this in the future:


Thank you. Can I not re-register the device after I do a "factory reset"?

If the hub was registered to you before a soft reset, it will remain registered to you after a soft reset. If you un-register a hub before (or after, though I'd do it before while the hub is still online to make things easiest) a soft reset, you can re-register it to yourself if you want, otherwise it will remain un-registered unless/until you or someone else registers it again. So, you really only need to un-register the hub if you plan on giving it to someone else. If you're keeping it for yourself, resetting the radios and doing a soft reset should be enough for what you need.

1 Like

I just tried this and encounter the following issue (screenshot attached)

I reset the ZWave radio
I reset the Zigbee radio
I ran "soft reset"

I get "Unknown Error Occurred." and the Hub is stuck and not reachable.
I pulled the power plug. It reboots with settings still intact and when I try to soft reset it gives me the same error again.

This is currently happening with the C7 model. LED is blue after starting the "soft reset" process and gets stuck there. Unplugging lets it boot with green LED.

That's the old Diagnostic Menu...

The current one looks like:

Screenshot 2023-03-18 at 12.42.41 PMI

can't say it makes a difference but maybe, just maybe, the path back from the diagnostic menu to a booting hub changed. Backwards compatibility with Hubitat is usually very good, but like I said.. maybe...

Make sure your Diagnostic Tool is up to date by following the instructions at the end of the document I linked to above (it does actually make a difference if the hub platform is newer than a certain version).


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.