2.3.1 upgrade - Lifx bulbs missing

After upgrading to 2.3.1 today my Lifx bulbs are missing from devices and from the Lifx Integration app. I have tried the refresh but the bulbs do not show up. They are still usable with the Lifx app but Hubitat can't see them.

Anyone else with Lifx bulbs having issues after upgrading ?

1 Like

You didn't specify which 2.3.1 you're asking about but I'm on and Lifx is normal and functional for me.

dev:331 2022-04-01 06:31:41.018 pm info LIFX Candle switch is off
dev:331 2022-04-01 06:31:38.904 pm info LIFX Candle switch is on --- It looks like it is resolved. I removed power from the bulbs and powered them back up and they appeared in the integration. Odd ...

1 Like

Yeah, no issues at all with mine through the beta to current. @bcopeland , any ideas on what may have happened?

I was going to suggest that they lost WiFi connectivity.. But looks like @m.p.frankland figured it out.

I just upgraded to and my LIFX bulbs are missing. They work perfectly in the LIFX app so it isn't a connectivity issue. I powered them off for over a minute each (3 bulbs) and they still aren't showing up in the hub either as installed or able to be added. It seems odd that they would disappear after a hub upgrade and powering bulbs on and off is not very practical. I rolled back the software to and the configuration file to yesterday's version but the bulbs still aren't there. I really need these bulbs working so any advice would be appreciated. Everything worked perfectly until the update earlier today.

I had one LIFX bulb that fell out of the app and off my Hub. I couldn't get it to add back into the app.

I got a warranty replacement--it wouldn't add back either.

My other bulb was still in the app but the hub lost it--at least until I deleted it (then it showed up as able to be selected--but I had already decided to get rid of them completely so I didn't bother trying to see if it would work).

Same thing happened to me after updating to yesterday. I had to power cycle all my bulbs and that brought them back online.

That's not my problem. The bulbs work perfectly in the LIFX app, it's just that my Hubitat C7 doesn't see them anymore and even with a power cycle it doesn't seem to work. I may revert my hub to and see if that helps. I looked through the logs some more and it appears it was after the 134 update that they disappeared. I have another hub with 2 bulbs and upgrading from 133 to 135 worked fine.

Something on your network is interfering with udp broadcasting....

I hadn't changed anything on my network except for a reboot of the router yesterday and that was in hopes it would help with this problem. Hubitat is a lot of work. When I upgraded to 133 I lost one of my mode changes and needed help to debug that then upgrading now I lost my LIFX bulbs.... Not good. 2.3.2 has caused nothing but wasted time for me.

It's not the platform. Lifx integration has been pretty static for a while. It relies on UDP broadcasting to find and use the bulbs. If UDP is beling blocked by something (firewall, router, access point) then the bulbs will have sever problems being seen by Hubitat. I have several bulbs, @bcopeland has literally 100's. Platform updates haven't killed them yet.

1 Like

Make sure that UPnP wasn't (accidentally) disabled during the reboot, and that multicast is still routed between the wireless and wired segments of the network, because Hubitat uses multicast to discover the bulbs.

It wasn't working before I rebooted. I'm running pfSense and I have my hub and lightbulbs on a separate VLAN for over a year. They all have the same addresses and this has always worked previously. I hadn't ever had uPnP turned on and the LIFX integration worked. I just enabled it on the IOT VLAN and nothing has changed. I hear what you are saying but this did work just fine until an upgrade or at least there were zero network changes from working to not working. Any other ideas would be appreciated.

Although I'm certain you haven't made any changes to your network setup, I would still encourage you to double check that multicast is being routed between the wired and wireless segments of that VLAN. This is because there have been multiple examples of LIFX bulbs not being discovered and Bond bridges not being discovered due to failures in multicast discovery.

And off course, in both instances, the native applications for those devices are not multicast dependent.


Ok. Thank you for the advice. I use Unifi APs and switches and a pfSense router and confirmed that multicast was not blocked on the Unifi network. I have wide open firewall rules on the IOT VLAN so there shouldn't be an issue there. I got this to work by downgrading to and loading the corresponding configuration file. I then waited for a network discovery and the bulbs showed back up. I then upgraded to and reloaded that config file. So far everything is working fine. I appreciate all of the help and believe that it was not directly the result of an upgrade but I really cannot explain what happened.

1 Like

I just upgraded to 2.3.3 today, and just like after upgrading to 2.3.2 I had this same exact issue. Had to power cycle all of my bulbs for them to work with hubitat again. It's hard to imagine it's a coincidence that this only happens whenever I install a new hubitat version. Very weird issue.