[] Dashboard disregards set Grid Gap

All my existing dashboards now seem to have a grid gap op 10px. When I set them to 0 and save the layout, the change is present. When I refresh the dashboard, it is set to 10px again.
Same seems to be in new dashboards.

Only seems to occur if you set a gap of "0" from within the "grid" window of the dashboard.
After setting it to "0" and you look at the layout.jsan, the gid gap is set to -1.
When manualy setting "gridGap": "0" and save, the setting is remembered.

Doesnt work for me at all, running latest code and grid gap still doesnt save and honor what I select.
That is if i set it to 0 (which is what I want) if I set it to 1 it sticks.

The setting seems to be disregarded when set in the UI, but did you try to set it in the layout.json?
That works for me:


Still an issue even in
If I set it in either the JSOn code or by the UI to 0, it resets to 10.
If I select 1 then it sticks, but I dont want any grid gap.

Try setting it to -1

tried that, it goes right back to 10.

When I set it in the layout file to 0, it stayes that way.
If I use the GUI, it resets to 10.

Yeah no go for me, no matter what i do it wont stick.

Version is:

Hmm, at the same version.
Did you try a new clean dash?

Yes., same issue.

I get the same thing. It honours a setting of 1, but whenever I set it to zero, either through the Grid section of the UI, or through the layout json, it always springs back to 10, if not straight away, certainly when I refresh the dashboard by clicking the green tick.

I can reproduce this.
When I create a new dashboard, set the grid gap to 0 my menu or in the layout, it reverts back to its original value.

Set double quotes around the 0, then the value is respected.


That worked for me, well spotted. This also allowed me then set it to zero through the UI, once I have introduced the double-quotes in the layout json.


I may have spoken too soon. The dashboard seems to have reverted back to 10.... Weird.... I'll keep playing around with it. Might need to make sure it is closed on all devices and apply the changes...

Looks like it was just a glitch, dashboard has maintained the gap = 0

1 Like