2.2.4 Virtual Thermostat Device Issue

My Hubitat Virtual Thermostats all stopped working after 2.4.4 install. Background info...the Hubitat T-stats no longer accept heating setpoints nor are able to communicate with Hubconnect running in the Smartthings hub (which run my Honeywell WIfi thermostats) since 2.4.4 install. Some of the settings appear locked up.

My T-stat setup between Hubitat and Smartthings has run fine for nearly two years until 2.4.4.

Played with the Hubitat T-stats a few days trying to find a problem without success. Also deleted the thermostat schedulers for those thermostats as well (Hubitat stock schedulers) to check if that was an issue. Not. Finally installed a brand new "test" virtual thermostat on one of my Hubitat hubs and am having same problems with that one as well. I'm now thinking there is a new bug that was introduced...maybe in the Virtual Thermostat device.

Another possibility.....could the new Thermostat Controller app introduces some code that gets left behind unintentionally when a thermostat controller device is deleted? I had briefly installed a thermostat controller for one of my thermostats after installing 2.4.4 to see how it worked, and then promptly uninstalled it since I didn't believe I needed the app. But since that time the behavior of my thermostats suggest that some other app is now controlling them. Maybe that app is an unseen and uninstalled version of a thermostat controller?

Anyone else seeing anything like this with the t-stats?

UPDATE. After sending this I decided to go back to previous 2.2.3 version. After going back and restoring database I found that my Dashboards no longer worked, due to not having security tokens. So then I went back to After restoring latest database the dashboards returned. Then I checked my devices and found that a thermostat controller device had reappeared in my device listings. I deleted it and after that...my virtual thermostats are all working perfectly. Weird!!! I'm think I'm going to stay put and not make any more changes for awhile and watch the support board to see what others are running into. 2.2.4 has a lot of amazing upgrades and with that I imagine there are going to be a few rough bumps to get it settled.

1 Like

There was a problem w/ released yesterday. If you were on it that was the likely issue - virtual thermostats were affected on my hub as well w/.142. Reverting to should make things fine again. HE will be releasing a revised update today.

That must have been it, thanks for the info.