2.2.4 and Z-Wave Repair

I have lots of old (non Plus) Z-wave devices.
So with the improved Z-wave Repair in 2.2.4, is it now recommended to run a Z-wave Repair upon installation of this firmware? And further, it is now recommended (or at least OK) to run periodic Z-wave Repairs?

I don’t know about periodic.. But if you are having issues, sure..

With pre-plus devices in the mix it is necessary to run repair sometimes..

2 Likes

@bobbyD @bcopeland
I started a z-wave repair last night and it appears to have stopped on the second to the last device... didn't error out, but just has not finished... been that was since about 1am... also, now many of my z-wave devices are non-responsive... not sure if i should leave it or do something like a re-boot?

Dumb question, but why do pre-plus device’s sometime require a zwave repair? What are the symptoms for requiring such a repair?

FYI for me, I had to restore my hub back to the previous OS and restore my database as well.. Guess 2.2.4 is not quite ready for prime time... I'll wait for the next revision... :slight_smile:

2.2.4 as well as 2.2.3 are not workable for me at all. I had to split Z-Wave devices between C-5 and C-7 to be able to use it. With 2.2.4 after each Soft Reboot all Z-Wave devices unreachable for 20 - 30 minutes, after that some of them might work. Routing algorithm tried to use one month old removed devices, they were not visible on Z-Wave detailed page nor on Topology map. It gave me a slight shock... and thinking what am I doing here. It looks like I have to move back to C-5 Z-Wave devices again for one more time.

Repair worked fine for me on 2.2.4. You may have an environmental issue (concrete wall, appliance, etc).

For anybody reading with problems. I suggest doing a restart of the hub, then wait 5 minutes after rebooting, (optional) then do a zwave repair, then give it an hour.

Eventually everything settled for me, in terms of device responsiveness, mesh routing and even some switches not responding.

I'll try rebooting and repair... But I just came here to report, 2.2.4 didn't help for me. Coincidentally the day after I updated I seem to have 2 incidents of total system non-responsivness in 24 hours. Not sure if the situation as a whole is worse than before, or if it's just a bad day.

Getting this thing working is beginning to feel like a part-time job.

2 Likes

Once it does work, though, you will be able to file a claim for unemployment.

EDIT: Perhaps you didn’t come from Wink or SmartThings. I had both before coming to Hubitat. I’ve seen the daily extended outages where nothing worked, and learned to ensure that there is a second, non-automation way (like wall switches) to make things function during outages. It’s not the end of the world to have to flip a wall switch. It’s way better with Hubitat.

3 Likes

I’m not sure your issues are actually zwave related. I have similar issues as described with non responsive “rules”. But sometimes these are zigbee devices (all zigbee devices within the rule).

I have found that this most often occurred with grouped devices that are within rules. If I tweak the group settings, the issues typically go away.

Just a thought, do any of you find these issues include grouped devices?