Still not Fixed for Presence Sensors

I tried to update to today, and for me my presence smartthings sensors still do not work correctly. They still go from present to not present frequently and do not report the correct battery percentage. I have tried to manually set the presence timeout and still does not change anything. This is not an issue using 2.2.3. Will this ever be fixed?

Try setting the default timeout and saving prefrences?

just checked my SmartThings presence events and I do not see any issues at all.
It maybe interference with your zigbee mesh or a battery problem with your device.

you could also try using the Xbee3 DH instead of the stock DH.

I have two in our cars and they have been working throughout 2.2.4. The battery percentage I do not believe, of course.

I did have an issue with one of them yesterday, and I plugged in another zigbee plug in the garage. This was on my wife's car, which is farther than mine from the previously sole zigbee plug in the garage. It could've been because of an open breaker in another room, or it could've been that reception was a little marginal, so I put in the extra plug. My car didn't have any problem.

It's a drag when the car's presence goes from here to gone and then back to here and the garage door opens and the car hasn't moved.

When I set the default preference, the logs still reflect the changing states.

I only see these issues when upgrading to v2.2.4. When I revert to 2.2.3 everything goes back to normal.

I haven't had mine that long. When the battery is failing, and the % can't be trusted, how do you know? Does it all of a sudden not work, or does it kind of fade away?

That's interesting. And it's zigbee.

Change the timeout settings to something other than you use to have, hit save, then put it back to what you really want and hit save again. This should clear everything up.

1 Like

Never really totally depend on the battery reporting, but its a nice judge to have. As for the real battery strength, it depends on the last state it was in. When its no longer strong enough to communicate with the mesh, it just stays in its last state.

YES. And I even started a thread on it:

I see you have issues with other zigbee devices.
I would agree with @velvetfoot and add more zigbee repeaters.

I have multiple, the mesh even shows open slots so that shouldnt be an issue

Ya gotta try what @nclark and I mentioned above. It worked for me when my garage doors were going up and down uncontrollably.

1 Like

ok, will give it a try.

What zigbee channel are you on?
I found zigbee channel 20 worked best for me.
What channel is you wifi using (make sure they are not the same)?
It maybe causing interference.

1 Like

Wifi is on Channel 1 and zigbee is on 21. They are pretty far apart so it shouldn't cause any interference.

Same here, when using Channel 20, I've had little to no problems, except when one of my zigbee lights started repeating everything it could, I put all lights on Hue Bridge and all is stable since!

Thanks,,,,seems setting the timeout to 15 then back to 2 did the trick.