[] Zwave single node repair doesn't seem to handle failure gracefully (?)

I intentionally tried to do a repair on my furthest out, most often to fail when doing a repair device. It failed, which is fine.

However, now every subsequent attempt fails too and I get network busy messages + the maximum retries have been exceeded immediately. I'll shut it down and pull power next, but thought I would mention it.

Example of what I see on each repair now:

Going to see if I can replicate any issues on node repair.

First went fine, moderate distance, about 30' from hub through a door and one wall.

This is the most distant Z-Wave device I have on my network, far corner of the house, outside on exterior wall. Three walls and about 45' or so.

So far no issues for me.

Both are Z-Wave Plus devices. a GE switch and a GE double-plug.

Also tried a Z-Wave switch (non-plus). Also went OK, no errors.

Couldn't command any zwave devices either after it got in that state, either.

Shutdown and power pull got it going again.

You mind showing me the stats and route of that device?

Repaired fine after the shutdown and power pull.

The very 1st time I did the repair it failed on "node unreachable", which I see on occasion.

Second repair, it got to to assigning route 1 and stopped. I hit repair 2 more times as I thought it was dead (it wasn't because it did eventually get to retries exceeded. But at that point it was dead - couldn't control any zwave devices.

Odd.. Thanks for the info.. Will look into this

No worries. Like I said, shutdown and power pull got me going again, so I'm fine.

1 Like

I know you are good.. I would like to track it down for the less technical savvy.

1 Like


Definitely seemed to get POed when it got to the max retries exceeded.

Yea.. Thatโ€™s never a good sign.. I have that code in there as a fallback.. But it should never hit that. Makes me suspect the lower level SDK didnโ€™t respond properly.


Looks like you are having the same failure I've been experiencing...

Just got this at my clients... excluded, included no auth - edge of network. Tried to repair a few times.. then

shutdown, pulled plug.. slow or not responding.

And all of a sudden it's responsive... hmmm going to let this sit over night. I'm too darn impatient.

Well, if the plug is pulled, I would be surprised if it did respond.

Seriously, are there any ghost nodes?

:sweat_smile: that certainly would do it!!

Yeah no ghosts..

1 Like

There is a Z-Wave busy warn at the end of the repair. Are there any of those still? Any chatty devices? Do you have a sniffer with you to see traffic?

Yeah haven't done that yet.. but am kinda holding off unless I have to.