[] SIMPLE Automation involving motion and sunset/sunrise DID NOT WORK Solved by .147

I just about finished adding back all my devices and tried to do a SIMPLE motion app with sunset-30/sunrise restriction. Because, you know, I have to re-create all my automations from my head. Imagine my reaction when this pops up. Fabulous. And then there's the ad on the top of the page.
edit: running latest firmware
edit2: repeatable


I redid it in baby steps.
It didn't like the -30 offset to sunset.
Is this a known bug? This used to work.
And then, BOOM, you can't edit it.
This is deja vu all over again.

Oh, yep, blew up on me too. I used a contact sensor instead of motion (the only sensor on this new C7 hub right now).

It looks like it is the offset causing issue. I can make the rule work without offset, just sunset and sunrise. Offset -30 and 30 both puke.

One other weird thing is there is no evidence (other than the log entry) that I even attempted to build a rule in the SA interface. Maybe because I couldn't save/done?


Do you have a day of the week restriction in there? I remember reading that there is a known bug (with an impending fix) for that condition.

No, just sunset-30/sunrise restriction with the motion.

It's not the motion, it's the restriction! I just put the same restriction in for a very simple rule with a contact sensor and it didn't work! Without the offset, fine. With the offset, not fine.

The sad thing is, you can't edit the rule. You just get some message about java you can't do anything about. I think this is what happened to a lot of my rules prior to my hard reset. I was using restrictions a lot. Update comes along, and booom. Who knows.

Nope, no days of the week.

For this test rule I just used a trigger (contact sensor), a switch, and this simple offset from sunset time restriction.

It might be related to that other bug, but it isn't quite the same as reported in that other thread.

How about this:
Using simple automation 1.1, I created a rule to turn on/off a light with motion sensor as trigger, with the restriction of between sunset and sunrise (no offset because that immediately bombs out, right?).
It didn't work! The light comes on in broad daylight.

Try it yourself. This is on latest firmware update.

.147 seems to have fixed it.
Simple rule with -30 offset to sunset doesn't bomb out anymore.
Light doesn't come on in the middle of the day.
I'd declare success, only it's still light out. :slight_smile:
edit: 6:00 PM: Success!


Great - glad they got that fixed. :slight_smile:

Maybe update your thread title to note the problem is solved. :slight_smile:


I did, a long time ago.
oops. the title. I did check the solution box.