2.2.3 Update - Unresponsive C5 Hub

Good to hear it’s working now. The previous time you tried updating; did you do it at night as well? Just wondering if doing the update closer to the maintenance window helped. Probably more likely the Ring integration. I have mode manager on my hub and didn’t have issues.

Not out of the danger zone yet.. my original upgrade lasted a few days but maybe it was a one off glitch or something. :crossed_fingers:

If not then the good news is the hub has a very simple setup that could help support figure out the issue vs others maybe..

1 Like

I don't have ring integration. My hub consists of:

  • Xiaomi sensors and buttons
  • Ikea and osram sockets
  • zwave sirens and keypad
  • A lot of devices communicating via MQTT (tasmota and Rpi)

After the update everything slowed down:

  • HSM disabled around 1m after badging the keypad.
  • When switching all lights on (mix of mqtt and zigbee) triggered via a zigbee button, 1 light would come every 10s or so, taking over a minute for all to switch on
  • lighting triggered by motion sensors also took around 10-20s to respond
  • automatic watering system didn't start on time and then soaked my wife as the PIR that detects movement and inhibits the system was too slow
  • Web interface very slow, taking around 5s to display list of devices, logging interface appeared inactive
  • Dashboards took over 1m to load or timed out my browser, live dashboards appeared not to update.

All MQTT Automation that doesn't use hubitat was not affected and continued to run as normal, eg RPI to Tasmota communications.

I have rolled back to 2.2.2 and everything is back to normal. I have read that it might get better after a few days but I can not be without lighting etc for that long.

Does anyone know if support have identified the problem? Do we know when a fix is due out?

The only thing I’ve seen identified so far are the Xiaomi community drivers. I haven’t seen anything else mentioned (and I have probably been on here way too much this past week).

1 Like

That is interessting as I have a lot of Xiaomi devices. Do you know if there is a fix?

We have a new beta version that trims states and events on startup, among other things. One of the common slowdown causes of general slowdown is a large number of either stored in the database, so there's a good chance this new beta will help once it becomes available. Right now, it is at a point of getting user feedback, so it shouldn't be too long.


Thanks for the feedback. I'll hangon until the new version is released. What version number should I be looking out for?

Anything newer than :slight_smile: Not trying to be a smart arse - the final number isn't set yet as it gets revved up if there are issues found in testing (hopefully not :slight_smile: ).

Reporting back... my C5 hub has been running fine since I (re)upgraded 3 days ago.. Has now been up longer than the first time I upgraded so all good so far.

Nothing really changed other than I updated the Unofficial Ring app to the latest version and removed Mode Manager app which I am not currently using. Also rebooted after making those changes. I don't think those apps really had any effect on the issue way or the other... but the Ring app is a custom app.

My hub was more than 5 times slower on 2.2.3 compared to 2.2.2. I left it overnight for the maintenance to run (and trim the events from the DB) which trimmed the backup from 6.5MB to 1.2MB. It was faster after the maintenance had run, but it was still 3 times slower than on 2.2.2. I've rolled back to 2.2.2.
This is on a C4 with zigbee and Z-wave disabled and all apps and devices disabled except for the hub watchdog. The only (now disabled) devices on this hub are devices from remote hubs coming in via HubConnect. Now that I have rolled back to 2.2.2 I have enabled all apps and devices again though which didn't affect the responsiveness of the hub (based on watchdog measurements of virtual switch). Zigbee and Z-wave radios are permanently disabled on this hub and the stick physically removed.

There is a new version of 2.2.3 out today. I have tried to install it as a test to see if the unresponsive hub issues have been resolved.

It has been stuck "Initializing Hub: 15%" for half an hour now so doesn't appear to be a great success unfortunately.

Which hub do you have? C3, C4, C5, C7?

Installed yesterday and my C-5 hub stuck at 'initialising 15%' for a long time, was just starting to worry when it sprung back to life and completed fine.

I updated 2 - C4's and 2 - C5's to "" and all is working well for me.

My main hub C4 did seem to take a little longer to start up at first (it has the most devices) but now reboots fairly quickly again. Could just be my imagination though.

My C4 is stuck at 15% too. I powered it off and on and I'm back at 15% again. Been about 15 minutes but I'll continue to wait after seeing note from @plumsden

There were some database updates in 2.2.3.. If you have a particularly large database, this process may take longer than usual.


Sure enough, the hub booted just fine. About 20 minutes I'd guess. Thanks all!


The latest 2.2.3 does a big one-time cleanup on startup. It might take a while depending on how many devices there are and how much event/state history is around at the time of upgrade. Give it time to complete, it's not really stuck.


Need a better progress bar then. :slight_smile: "Pruning xxx of yyy records"

Or, we can just all be patient. :slight_smile: :slight_smile: :slight_smile:


Ok, so i need to be a bit more patient! Install finished and hub looks to be running well.

Thanks guys for sorting this out