WebUI does not load - WebUI slow

Since update to WebUI is a hit and miss. Even it UI loads once, after some time it stop loading and times out.
I have to power cycle hub multiple times to get back to WebUI
I see that http://<local.ip>/ui2/js/jquery-3.4.0.min.js” fails to load, perhaps due to its size

How long after a power cycle? The hub is still running initialization for a while after the web UI reappears. You may not have given it time to settle down. Mine takes up to thirty minutes.

1 Like

I tried with different times from few hours to 1hr after reboot to 10 min after reboot, there is no pattern. Additionally, a boot screen should be available right away with boot up progress bar

If you ask I'm pretty sure they are going to say nothing in the UI changed that would cause this. It's probably time to start disabling apps (not removing but disabling) to troubleshoot general performance issues on the hub

I opened support request and it is not apps because hub becomes unresponsive right away... they should be able to fix it or pinpoint the app.

Have you tried a soft reset? Do the logs indicate database corruption?

Here's the soft reset process:

yep, that was first thing support advised, web ui becomes available again after soft reset and then dies again in 1hr or so...

and with 2.2.1 web ui is literally flying! no changes on my side, no re-configuration or rules, no removing or adding apps, everything is exactly same as when web ui was slow, so it is clearly bug fixed in the two latest releases...