2.1.4 Fails to complete install - Applying update for hours

I invoked the update process from to the version of 2.1.4 posted as of August 26. It did the download and then started to apply the update. This process has usually taken about 5 or 10 minutes. It has been over two hours in the applying update screen.

My question is what, if anything, can I do at this point to recover and avoid bricking the HE?


Reboot the hub, then try to update after reboot If you are unable to go to the settings menu.

Type in

your hub ip:8081 then select reboot hub

1 Like

Thank you, that worked.

1 Like

@bravenel Is there release notes for this I'm not finding?

I've got the same problem. Reboot has not worked.. any other ideas?

Go to port 8081, click on "Restore Previous Version" and select the latest version there. That should be step one, not the reboot process if you are stuck at applying update.

Also, did you go to port 8081 and select reboot there or did you only try it from the main UI?

Yes i tried reboot from the 8081 menu.
I will give the restore previous version.. ago..

thank you Chuck that worked..on the latest version now..