Bug (Z-Wave Pairing)

Trying to pair two new Aeotec sirens and of course I'm still having problems with the endless z-wave initializing.... Seriously, several of us have mentioned this as an issue now for a few weeks... I had hoped there was an update in this latest release...

Anyway, I've played this game before... When it doesn't finish pairing and I have to start over, I have to exclude the device first...

Here is the latest bug (in addition to the original pairing issue that everyone keeps ignoring).

When you hit exclude, the countdown timer starts and even when the device excludes itself, the timer continues... When you hit the button to stop exclusion, it doens't work and keeps counting down to 0...

This can be very problematic say you or someone in the house accidentally hits a button or switch somewhere...

EDIT: You can't stop the inclusion timer either.... :exploding_head:

Most z-wave devices I have used require holding a button/switch for a period of time, or pushing in a specific pattern, in order to exclude.

As to stopping the exclusion process, if you change to another screen, the exclusion process is supposed to stop. Not saying this is a fix or anything but a possible work around in the meantime. I saw this mentioned by one of the staff before.

What browser. I missed any reports of exclusion timer not stopping. I am able to start and stop the exclusion by using the same button that starts and stops it.

If it excluded a device it automatically exits exclude mode. And you can verify this by showing past logs or watching it in live logs.

Again, pleas let me know the browser and any screenshots of logs, the error, etc you can provide would help.

What was added in 2.1.1 is that it will keep trying to initialize even if the timer runs out. But if it doesn't complete the pairing, there is nothing at that point anything can be done. It stopped communicating. Typically due to something environmental or driver fingerprinting didn't match.

1 Like

Hey brother, I am at my wits end here... Over the last few weeks I have tried to pair all kinds of different z-wave devices with only about a 10% success rate...

If this is not something bigger than me, then I have a bad hub...

It has worked perfectly for the last few months and I have 170 devices on it now... Recently though, I have given up on z-wave and returned items for zigbee models...

Today I got two Aeotec sirens in the mail and tried to pair them... I have been hoping the latest updates solved my problems. Today I am seriously frustrated as it again hangs in initializing mode...

I have tried two different browsers... Both Chrome and Firefox... I even tried Edge last week but it didn't work and I normally don't use it anyway...

Today, in addition to the perpetual initializing and never finalizing, now the buttons don't seem to control the include or exclude process either...

I can try to record my screen to give you an example... It must be noted however, zigbee has been pairing perfectly and I have been adding apps and virtual devices as well... I love this platform, but I think my z-wave portion is somehow messed up...

It was so bad about a week ago, I went through every "position" in the ID's, each time failing to finish and each time rolling over to a new one...

Maybe the ID's have not cleared out like they are supposed to? Maybe I have ghost devices in the system I can't see?

Anyway, I will try to record my screen with me hitting start/stop and the timer running in the background...

Thanks for your help....

1 Like

It could be a bad radio. That stuff just happens sometimes. You’re in contact with @bobbyD about this issue I assume. Also if you contact him by support@hubitat.com, he has better tracking of your case.

Here is a video showing my pairing woes... It shows the previous failed attempted ghost spots and shows as soon as I hit the button on the device, a third initializing... Just to show you what I'm talking about, I tried to stop the process... Both buttons would not work... This was on Firefox but its the same on Chrome...

Yes stopping the timer when it's initializing is by design, arguably the display should be better.

Best watch live logging as the inclusion stops immediately after it finds a new device.

Z-Wave is far more fragile than zigbee during the pairing process, especially during the s0 key exchange.

Run a Z-Wave repair, wait for it to complete.

Couple things to try, reboot hub and wait about 10 minutes.

Then disable any of the more chatty Z-Wave devices in the list view of devices and any apps or lan / cloud drivers that might be heavy in activity.

Try to exclude the Z-Wave device first. If you get an unknown device excluded, that is a good thing.

Then, start the Z-Wave pairing and push the buttons on the device to join. Watch live logging in another tab.

I get you are at your wits end, but given the level of fustration, it isn't helping trying to do the same over again, expecting different results.

Start with the Z-Wave repair. Give it 24 hours so the system can clean up the ghost devices. Make sure you aren't at the 4 hop repeater limit for zwave devices and no errors during the repair.

Let the mesh settle, don't keep trying the same thing. It will either pair on the first try or it won't.

We continue work on improving the device discovery and management of resources on busier hubs. There are some significant improvements from 2.1.0 to 2.1.1 that should help.

If the above doesn't work, reach out to support and they can see if there are some more options to explore.

1 Like

Thanks... Will do... I've done most of those things already... I can also say that every time I run an exclude, it removes the "unknown device". That is working great..

I was a long time IRIS customer (since the beginning) so I know how z-wave can be fickle...

I've watched live logging as well... It doesn't say much... Almost immediately recognizes and begins initiating, then nothing after that...

I've run two repairs... No errors... I'm not over the 4 hop limit as I'm pairing these devices near the hub.

I'm truly afraid to contact support as I don't really want to swap out the device... That will be many more hours of pairing all over...

I will go through your list again... Can't say I'm not thorough... :joy:

On a side note, hopefully this can be done automatically along with the same thing happening with zwave repairs in future UI improvements.....sure would have helped learning how the hub operates for us new people.

What done automatically?

Some variation of a separate tab opening up with the live logs.

1 Like

It's something that is meant to run in the background. Live logging or past logs show the results. I get your request but it's not something I'd like to divert resources to put it in one spot right now.

Z-Wave repair is something that should be run before and after including or removing devices.

In larger installs it may take up to 48 hours to settle down. I always attempt to pair in place and not close to hub. The only thing that has to be done close to hub is exclusion.

Always factory reset a device if possible. This is far better than excluding.

If the Z-Wave device won't pair in place via good routes, it's probably not going to work right if you pair it close to the hub and then move it later anyway.

Z-Wave has a technical limit of 232 devices. But due to the nature of some of them being far more chatty then others, a practical limit may be far less especially given the 4 hop maximum and security overhead. This of course is 100% environmental.

Disabling the chatty devices, custom drivers and/or busy apps will all help the pairing process do its thing. After it pairs, I would then enable the devices and apps slowly and see if any introduce instability back into the system.

I've seen one bad device bring an entire mesh down. Finding it or other causes isn't easy. But can be done.

Fair enough.....just a thought

Morning Patrick and HE staff... Here is a log sample from this morning...

I ran a z-wave repair last night with no errors... rebooted the hub and tried to add my sirens again this morning...

As you can see, the devices initialize but never fully complete ... You can see that in the video I posted above as well...

I'm going to email support this morning...

sys:12019-06-12 06:02:56.276 infoUnknown Z-Wave device excluded.
sys:12019-06-12 06:02:51.774 infoZ-Wave Exclude Started for 30 Seconds
sys:12019-06-12 06:01:41.868 infoZ-Wave Discovery Stopped
sys:12019-06-12 06:00:45.847 infoInitializing Z-Wave Device : 9A
sys:12019-06-12 06:00:40.853 infoZ-Wave Discovery Running
sys:12019-06-12 05:56:27.294 infoUnknown Z-Wave device excluded.
sys:12019-06-12 05:56:25.289 infoZ-Wave Exclude Started for 30 Seconds
sys:12019-06-12 05:55:24.293 infoUnknown Z-Wave device excluded.
sys:12019-06-12 05:55:22.053 infoZ-Wave Exclude Started for 30 Seconds
sys:12019-06-12 05:55:17.951 infoUnknown Z-Wave device excluded.
sys:12019-06-12 05:55:12.973 infoZ-Wave Exclude Started for 30 Seconds
sys:12019-06-12 05:54:35.680 infoZ-Wave Discovery Stopped
sys:12019-06-12 05:53:49.685 infoInitializing Z-Wave Device : 99
sys:12019-06-12 05:53:34.666 infoZ-Wave Discovery Running
sys:12019-06-12 05:53:26.350 infoUnknown Z-Wave device excluded.
sys:12019-06-12 05:53:09.658 infoZ-Wave Exclude Started for 30 Seconds
sys:12019-06-12 05:53:03.976 infoUnknown Z-Wave device excluded.
sys:12019-06-12 05:52:47.709 infoZ-Wave Exclude Started for 30 Seconds
sys:12019-06-12 05:51:05.558 infoZ-Wave Discovery Stopped
sys:12019-06-12 05:50:09.545 infoInitializing Z-Wave Device : 98
sys:12019-06-12 05:50:04.526 infoZ-Wave Discovery Running

This is golden advice - I wish it were in some FAQ or more prominently visible.

1 Like

There is information about Z-Wave repair in this doc.


The thing is, there’s a lot of variables, and expectations are not always in line with what’s possible. If you have a mix of Z-Wave and Z-Wave plus devices for example, your experience and results are going to be very different from someone with all plus devices. So many factors with Z-Wave. Reason I’m not a fan.


I agree with your conclusions on z-wave. But there are similar issues with zigbee as well. In addition to protocol version (1.2HA, LL, 3.0 etc), there's also vendor-specific extensions ......

1 Like

There are issue with protocol mismatches agreed. But the nice thing about Zigbee is it's self-healing, plus failed pairings and dropped devices doesn't leave a trail of Zombies the hub has to clean up. Z-Wave plus has explorer frames to try to do the same self-healing of the mesh, but it's not as good and doesn't always work in a timely matter.

1 Like

Very interesting. How do I tell how many hops a device is using? Is there a zwave map available?
How do I disable a device driver/app? I assume you mean Wemo Connect, Tplink, etc. and not Rules Engine apps.