Zwave troubles - completely nonresponsive now

I've had great success with my Hubitat C-8 but am now in the process of removing some devices because of a planned move from this house. I have mostly zwave devices for interior lights and exterior lights. Once I finish our move I'll leave the exterior devices for the next owner, but will remove all interior devices.

I physically removed two blinds (z-wave) last week without excluding them. Today I force removed them from the hub.
As expected the zwave mesh failed, and I've been trying to repair all morning.
I have updated firmware to

Currently no zwave device is responsive. I've manually toggled most devices, and performed Zwave-Rebuild many times.
I'm tempted to remove all internal devices (will need to do this anyway prior to move in a month) and rebuild with brand new inclusion procedure for the exterior lights.

I cannot find instructions for how to completely rebuild. Should I factory reset the C-8? Is this the best thing for me to do? Is there a better way to diagnose failed mesh network of current devices?

  1. Do a "shutdown" from the hub's Settings menu.
  2. Then remove power from the hub.
  3. Restore power to the hub after ~30 seconds.

A post was split to a new topic: Zwave network fails after 15-20 minutes of uptime



Follow the power down and reboot advice above, and if still having issues please read this post and provide the info requested, especially the Z-Wave section.


I did the power down and wait 30 secs, then power up
I am trying to remove my failed nodes (which are gone) from the Zwave network. There are six devices. Two deleted fine, but I'm getting errors now "Failed node {XX} remove status: 0 SDK failure node is no longer in failed node list

OK Update to my situation. I tried to restore a past backup, which included the Zwave config, and last night things seemed fine.
This morning ALL my devices are nonresponsive, and due to some urgent tasks related to our planned move, I had to remove my internal devices (six). Now I'm trying to force-remove them from the list of devices, and cannot.
I click 'Refresh' in the actions column of the Zwave-details page (pic1 below)
Then I click 'Remove' when the button changes name (pic2 below)
Afterwards the System logs show me that the node is not in the failed node list (pic3 below)
Meanwhile I'm trying to monitor the Z-Wave logs (per instructions sent on earlier reply) but the Z-Wave Logs are completely empty (pic4 below)

I need to do this for six devices that are physically removed from my network





This is not expected.....

So a cloud backup with the Zwave radio? Why?

Did this allow your remaining connected devices to work, even if only for a little while?

Z-wave logs is mostly useless, I dont think I ever said to check that.

That Node 0x02 you are showing will not remove using the hub because it is showing more than 1 neighbor.

I am not sure why are determined to remove all these nodes, you did not even answer all the questions posed in the READ FIRST post.

Ah apologies - I didn't click into the read first post - just saw the initial paragraph indicating to share screen shots.
Here is more thorough reply

  • How is Hub being powered? Supplied power block or other (explain)
    Hub is powered by the supplied power block plugged into a power strip plugged into the wall. It is near a Lutron Caseta hub (now disabled and not powered) and an IKEA Tradfri hub (not powered) and an Xfinity cable modem. The CAT6 cable is connected from the HE to a Netgear 5-port switch, which connects to the Xfinith modem

    • PoE power (with splitter) is known to cause major Z-Wave issues on the C-8 hub.
      PoE is not being used
  • Screenshots showing entire Z-Wave details Page
    top of page through node 0x04 pic

0x05 through 0x0e

0x0e through 0x22

0x22 through last item

Regarding my comment about the Z-wave logs - it was in response to a comment in the help doc saying to keep the log open (from the side panel) - so I shared the logs that seem to have value (primary menu option called Logs from HE menu on left side) vs. the 'View logs' button in the Zwave Details page

FWIW I'm willing to accept that my issue about removing the devices physically from the Zwave mesh caused severe issues. If that's the case I'm willing to rebuild from scratch.
After I had to physically remove them this morning, I thought I could digitally remove them using the menu. That's what has been causing the challenges today

Power down the hub and remove power for 30 seconds again. When it boots back up do not click any of the refresh or remove buttons on the z-wave details. Are the remaining connected devices working? If devices do not work after reboot, you may have removed critical repeaters from the mesh, crippling it, the only solution would be to add repeaters back in.

If they do work (even if only for a short time) you have a couple of options to clean things up.

  • Ignore the ghost nodes for now, in a few days check back and see if the neighbor count has dropped to 1, if it does then you should be able to refresh and remove.
  • Try a full z-wave repair, this may help speed up the process of dropping the dead nodes to 1 neighbor.
  • Use the Z-wave mesh tool [BETA] A Z-Wave Mesh Tool [C7 and 2.2.4+ Only] to look at what the neighbor nodes are that the ghost devices are hanging onto (use the > arrow in that app to see). Once you have that, if you remove the neighbor node properly by excluding then the ghost node should also be removable.
  • Total Z-wave radio reset and start from scratch, this is more involved than just reset and start over so not even going to explain it all here.

OK - did the powerdown trick, no button-pushing after restart

Are the remaining connected devices working?

Yes - it appears most devices work!

Try a full z-wave repair


Use the Z-wave mesh tool

I installed the beta Z-wave mesh tool in the Apps Code and enabled OAuth. Stupid question but I don't know how to launch the app.

I'll wait a few days for the ghost nodes neighbor count to drop to 1. Then try to remove them

Thanks so much!

1 Like

In the apps list click + Add user app and select it from the list, once it loads click Done right away to install it fully. Then it will be in your apps list on the hub going forward.

1 Like

Really appreciate the help - this seems to be working so much better now.
I noticed this morning that the neighbor count on one of the ghost devices dropped to 1, and I was able to remove it.

Some of the ghost devices have multiple neighbors which are also ghost devices. Any advice on that or will that eventually go away?

see Node 0x5 with 4 neighbors. It is a ghost device, with neighbors of the Hub, an existing device [Landscape Lights] and two other ghost devices 0x2, 0x3

1 Like

Some ghosted nodes seem to get stuck with neighbors that never go away, not sure why. It usually is other nodes which cannot have a repair done on them (battery or dead nodes). So if tey are all neighbors of each other those may never go away. (Also if their only neighbors are other dead nodes they are probably not doing any harm to the mesh).

Your other option to get rid of them is using brute force with a USB stick secondary controller. Here is guide about it: How To: Remove Z-Wave Ghosts (including using a UZB Stick)

One other option I had thought of but I don't think anyone has tried, would be to do a z-wave replace on those nodes. The idea would be to some other extra device paired to that node using the z-wave replace feature. Then once it is paired, you can do a proper exclusion and remove it fully. This should, in theory, work perfectly. You just need an extra Z-wave device to do it with. Here is my guide on using Z-wave replace: [Guide] Updating Firmware and ZWave Replace - #2 by eppower