ZWave Slow to Acknowledge

My Zwave devices when I turn on and off respond quickly. But the dashboard and the status of the device are very slow to update. I've tried changing the preferences but it doesn't seem to matter. Is there a way to adjust this? It seems to stay in this "sending" mode until I refresh the dashboard.

If you made sure this is not a problem with your web browser, consider activating debug-logging for one of the affected devices to see where the the communication gets stuck.

Does this really affect all your Z-Wave devices?
As for me, I found out, that my Oomi bulbs take up to 2,5s to report their status, even though the light turns on immediately, Qubino or Aeotec switches do way faster.
So, what devices are you talking about?

I have ruled out the browser issue since other zwave and my Wemo/LIFX devices are working fine.

I am moving devices over from ST and so it’s possible I did something wrong although the device is acting right and turn on and off quickly. The only issue is the dashboard not showing the correct state.

I’m thinking I need to install polling and set that up. It’s possible these are not zwave plus devices. I also need to set up an iOS widget as walking from the office to see these devices is doubling my daily steps!

Non-plus Zwave don't report instant status unless polled. Use the polling option carefully, if you do too many things it really slows the hub down.

With that being said, do you have enough line powered and/or repeater devices to have a strong Zwave mesh? If something is borderline communicating, it might work well enough to turn on and off, yet take a while to report back to the hub.

If you can tell the name and model of of the device in question, someone might have more specific information about how well it works within Hubitat. Also include what driver (Device Type) it is using, some devices occasionally work better with a different driver.

@neonturbo The switches that are killing me are Aeotec Smart Energy Switches. Unfortunately I have these for most of the lighting in my backyard and they are currently super hard to turn on and off via the dashboard. I had them all working pretty well with ST and I've got them in the same place and Hubitat in the same place. It took me a while to get the mesh working well in ST so I tried to keep it all the same.

It looks like my network is jacked up with a bunch of rogue entries. Not sure how to delete those as I've tried to remove them and run multiple Zwave network repairs.

You will want to change that power reporting. That is killing you. You are sending TONS of power reports. You do not want to set to 5W AND 10% AND every few seconds, that sends dozens if not hundreds of power reports, which is overwhelming your hub.

You DO want to pick one or maybe two of those 3 reports to use. And then tweak the ones you do use up as far as you can and still get reports.

What are these power reporting devices watching? Things like wash machines 5W setting would be ridiculous as most draw in the hundreds of watts when running. A bulb or something, that might be appropriate.

1 Like

Thanks @neonturbo. I disabled all of those wattage reports since although it’s interesting it’s only something I look at occasionally. These switches have strings of lights on them and I only really care about the wattage when I’m adding strings or trying to reduce usage by replacing a set with LEDs.

Any idea on how to get rid of those un-identified entries? I’ve tried removing/repairing/discovery/zwave network repairs but can’t drop.

Most seemed to disappear with the nightly cleanup but there is still one:

0x01 (001) OK in: , out: S2 Access Control

If it is what I think this is, you don't want to remove it.

In a C7, the first (from memory) 5 entries are the hub itself.

1 Like

Got these all fixed finally. 1/ replacing some of these with zwave+, 2/ using them as a repeater as opposed to operating a device and 3/ for those still have a device on them, am polling every two minutes to get the proper state.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.