Zwave include ZDS-200NA

I am having trouble including zwave Remotek ZDS-200NA in hubitat C7. I believed I made a mistake buy plugging the device and start including other devices (1 Zooz ZSE41 Open | Close and 1 Aeotec Wallmote Quad), Both of them were included no problem, When I tried including ZDS-200NA automatically indicates 1 device found and stays there on that screen without recognizing any new device. I press the blue ON/OFF/DIMMER/PROG Push button 3 times following the instructions on the Remotek and nothing happens.
Thank you for your feedback

Same thing happened with Ecolink ECDWZWAVE25ECO when i tried including

Have you read about Ghosts? Do you have any that you haven't fixed? Did you read about using Exclude before Include to assist with Ghost Prevention?

Two of the devices you mention are Battery devices and can't act as repeaters. Are you Including that Remotek ZDS-200NA close enough to the hub to be in range?

Finding a device then not completing the Include often indicates the device went to sleep before completing.. trying to save battery.

You could post images of your ZWave Details page and we can review it for mesh issues.

1 Like

Thank you for the feedback. I did some research and now I understand what you mention. The C7 HE was installed in another property and I executed reset Zwave Radio and start including the new zwave devices but make the mistake of including non repeating devices. Since I have include 2 devices (both no-repeaters) would you recommend to reset Zwave radio again and start all over? Is it necessary to unregister the hub and start from scratch?

You can add repeaters now, and the existing devices will eventually find a path back, Just be patient with those.

On the other hand it's pretty fast to reset the radio and start over. Resetting the radio doesn't need to unregister.