Zwave firmware 7.18.1 update

I saw at the bottom of the 2.3.4 release notes that zwave firmware 7.18.1 is available. I saw a big improvement when the 7.17 firmware released and was just wondering what we can expect from this update. I didn't see a thread on this already, so I apologize if there is one I missed.

2 Likes

Here you go

*originally posted by @ogiewon in the restricted Beta category.

3 Likes

I just got an error when I tried to update.
Should I try again?

I have noticed that some of my large rules to turn on/off many devices have been even better with the 7.18 update. They used to occasionally have a short lag in the middle but especially this past week my going to bed action that pretty much shuts down everything, has been very smooth and reliable.

Yes it can be finicky just like the last one. Mine worked first try. Other people had to do a full shut down, boot up, wait a few minutes, then go in and update. Sometimes this did not even work the first try.

2 Likes

This is what I get. When I try to do it again, it first says failed to start and then:

Mine updated on first attempt, but as Jeff said, other beta folks had to try numerous times before success.

I'm sure some of them will share tips & tricks here in the next day or so now that this release is GA.

1 Like

Rebooting hub and trying again did the trick.

1 Like

Just as general info...

Typical fixes for problems updating the Z-Wave FW are, from simplest to more involved:

  1. Reboot. Try again.

  2. Reboot. After rebooting go to the Z-Wave Details page and let it sit for 10m. (When the Z-Wave Details page loads there is a lot of background activity happening that you want to subside before you start the update.) Then try again.

  3. Shut down your hub. Pull power at the wall (plug on hub can be fragile). Wait a minute. Plug hub back in and then go to Z-Wave Details page, wait 10m, try again.

It took me one try on one C7, five tries on my other C7, so very much a YMMV situation.

4 Likes

I have a Zen34 button that turns all the lights in the house either on or off. I have all the switches as GE/Jasco so there's a lot. I don't find any difference from the last update. It takes about 8 seconds total. There's still a short delay mid cycle. They all work though. Maybe good to give them some exercise once in a while, lol.

Is the "Optional Z-Wave firmware 7.18.1" for C-7 Hubs only?

Yes C7 only, its a 700 series zwave update, I dont think there have been any new significant (if any at all) updates for the 500 series chips.

1 Like

Thank you. Updating the C-7 now. I didn't see it on the C-4's Z-Wave page but wanted to be sure.

My 7.18.1 firmware update completed on the first attempt. No reboot was prompted afterwards but I did one anyway.

2 Likes

I completed the update with no issues. My only question - is there a place where you can tell what Z-Wave firmware you are running? It doesn't show up under up details or under z-wave details that I can find. Thanks!

The http://hubitat.local/hub/zwaveVersion endpoint will show the current version information (replace hubitat.local with your IP if that doesn't work or you know it).

3 Likes

But what does it all mean? :slight_smile:
VersionReport(zWaveLibraryType:7, zWaveProtocolVersion:7, zWaveProtocolSubVersion:18, firmware0Version:7, firmware0SubVersion:18, hardwareVersion:1, firmwareTargets:1, targetVersions:[[target:1, version:7, subVersion:15]])

Says that the hub is running on ZWave 7.18 firmware and utilizing the 7.15 SDK (software development kit) libraries, i.e. you are at the highest revision available on HE.

4 Likes

Thanks - since the information is readily available, may be a nice feature to add to the Hub Details page so it is easy to find for the average user.

1 Like

Yeah, I think this is something @bcopeland was thinking about.

3 Likes

Thought mine went OK after 7.18 upgrade this past weekend, but today around 11:30 AM, all of my z-wave devices stopped working. Rebooted - still not working. Z-wave page showed almost everything pending, failed, etc. Shut down hub and pulled the plug. After restart everything came back online.

Thought it somehow completely killed z-wave radio function on the hub! Phew!

Download the Hubitat app