Zigbee Pairing in General


I have one of @iharyadi Zigbee sensors. I had it paired and running fine a few weeks ago. As I've been working on something else I through it in the ESD bag and left it there for a few weeks.

In the meantime I deleted it from Hubitat, and installed several upgrades

Today I pull it out and tried to pair it and received no response from Hubitat.
I then performed the sensor reset (plug in with button pushed, wait 2 seconds then release the button)

Still won't pair.

Now this is the only Zigbee device I have. When I first received it it paired so easily I forgot the steps I followed.

So I guess I could have damaged the sensor (not likely but possible) or somethings have change with Zigbee and Hubitat. Can someone remind me of the steps to pair this device?

Just an aside:
I searched the internet for the above topic and found many instructions like ".... pair it like any zigbee device..."
It reminded me of an old recipe for roasted pig. The recipe started with the following instructions: "Prepare the pig in the usual manner" :slight_smile:

1 Like

Thanks @JohnRob. Needed a chuckle right now. :joy:

I too have pulled my sensor from I got from @iharyadi while I'm (unbelievably) still waiting for my Xbee to arrive so I can use it in conjunction with the some testing. Can't say I've been as careful with mine as you have. As I recall, the thing paired so easily when I clicked "Discover", that it might have as well just reached out and clicked the "Discover" button itself when I removed it from the anti-static bag Iman sent it in. :wink:

I'm going down the same Xbee path as you, however I'm sure I'll be far behind. I have the Xbee, Xbee Grove board. I received then rather quickly from SymmetryElectronics.com they are an authorized ZigBee dealer with decent prices and relatively fast shipping. I think from order to receipt was a little over a week.
I also ordered the adapter board from an eBay seller. I think it is the same you posted a photo of. I have that as well.


As I am still developing the sensor, I still pair and unpair my sensor up to latest hubitat version. The sensor show up every time.

I suggest give the button a try again for 2 to 3 second.

Well John, I took a bullet for you. :grin: I looked and saw driver was still there. I hadn't deleted it like I thought. Plugged in the sensor and all was well. So I uninstalled my driver and I also cannot get it to show up again when trying to pair it. :unamused:

Tried removing the code and saving it again from @iharyadi 's repo (sounds odd I know, but it worked for me with another driver, but it wasn't zigbee). That didn't help. Rebooted the hub, but still not showing up during discovery. So I'm in the same boat now :joy:

I'm sure we'll get it sorted out soon.

Held for up to 15 and still didn't work. Tried pulsing the button too. Nothing.

Pulsating it would not work. It was not coded that way. Holding the button for 2 to 5 second while plugging in into the power should do it.

I left the sensor powered up for about an hour while I went off doing something else. Came back clicked discover and bingo it paired!

I guess it was ticked off I ignored it for the 2 weeks :slight_smile:


I am :relieved::smiley::smiley::confused:

Wow Iman, I do not remember doing that. I think I just hit the button after plugging it in last time. I'm possibly mistaken about that though.

It's working now. All good. Thank you for helping us both!

Not a problem. It is my pleasure. I happy you guys playing with it.

:grin: If you call pairing it "playing". I haven't given your wonderful device my due attention, but I very much plan to spend some quality time testing soon.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.