Zigbee Mocreo Temp Sensors not pairing

Hi there

Recently purchased a Hubitat C-8 and I am trying to pair some Mocreo ST4 temp sensors to it alas with not much luck.

These are zigbee based devices and on attempting to add them the Hubitat finds the sensor and attempts to initialise it however the pairing fails. Hubitat firmware is all up to date and I've factory reset the sensor but for the life of me can't get it to connect.

Sensor: https://manuals.plus/mocreo/st4-temperature-sensor-manual
https://mocreo.com/products/temperature-sensor/st4-st5/

Any help would be much appreciated!

Thanks

I have the same issue. Did you figure out how to connect them??

Did you try assigning HE inbuilt Generic Zigbee Temperature driver and then pairing the device again to your hub (without deleting it) ?

What model is your HE hub?

You sir are very lucky I left myself following this post.. here is the answer you seek:

Hello T,

Thank you for contacting MOCREO!

We apologize for the problem you are experiencing. Based on your description, I would like to explain to you that:

The MOCREO ST4 Sensor utilizes a non-standard Zigbee protocol, which may be the reason why you are unable to establish a connection with the ST4 Sensor via the Habitat Zigbee controller. Currently, the ST4 Sensor does not support establishing a connection with other third-party gateways and other relay devices.

If you wish to deploy locally, MOCREO ST8 Sensor is a fully deployed device running locally, the operation of real-time data you add or display on the APP side is completed by the cell phone and ST8 based on BLE to complete the signal transmission. You can view the monitoring data reported by ST8 Sensor from your cell phone. You can visit the following link for more details about ST8 Sensor:

https://www.amazon.com/dp/B0CLLG6HK3

I apologize for the inconvenience caused to you in using the product, please contact me again if you have further questions!

Kind Regards,

{REDACTED}

MOCREO Support

My purpose was looking for a temperature sensor and the mocreo fit the bill, along with the hubitat I would be able to have a non-cloud solution which would work for me. In the end I gave up trying to use these similar solutions and am now in development with a programmer in which we are building a solution purely for the requirements I needed.

In relation to what kkossev mentioned to try, I thought I would add in that I too tried every possible combination however none worked for me. This was a fair few months ago now and who knows, maybe it might work now but I couldn't for the life of me get it connected.

Goodluck! Hope that helped and if I can be of any further assistance please let me know.

1 Like