Zigbee bulb dims down but not up!

I have a LEDVANCE Smart+ LED bulb paired as a "Generic Zigbee Bulb" and showing in the Device view as a "LEDVANCE DIM".

I control this with a Philips Hue dimmer switch paired as a "Philips Dimmer Button Controller V2" showing in the Device view as model "RWL022".

I've used Button Controller 5.1 to create rules for each of the buttons:

When I hold button 3 the bulb dims and stops dimming when I release. However, when I hold button 2, expecting the bulb to brighten, it does nothing. If I use the Device interface I can both dim and brighten the bulb using the start and stop level change buttons as expected.

I have worked around the issue by programming button 2 pushed to increase brightness by 10 and this works as expected.

I do not have a Hue bridge, both devices are connected directly to HE.

Any help would be most appreciated.

I do not have any Philips Hue Dimmer Switches... However, maybe I can offer some troubleshooting advice.

Step 1: For now, please ignore the Button Controller 5.1 rule. Instead, please open the Device Details page for the Hue Dimmer Switch. Watch the Attribute values for Pushed, Held, and Released on the web page, while you perform those functions on each of the physical Hue Dimmer Switch's buttons. Do they all register properly? If so, move on to step 2 below.

Step 2: Now, open the device details page for your LED Bulb. Use the "Start Level Change" and "Stop Level Change" commands, for both UP and DOWN, and monitor the bulb to see if it reacts correctly or not. If the bulb is behaving as expected, move on to step 3. (Just re-read your post, and it looks like you've already tested this. Nice!)

Step 3: If both physical devices are performing as expected, per the tests above, then we can safely assume there is an issue with the automation (i.e. the Button Controller 5.1 rule.) Delete the Button Controller rule, and try recreating it to see if it then starts working. Or, try building it using a different app, like Rule Machine.

Personally, I really like the community Advanced Button Controller (ABC) App. I use it with Lutron Pico remotes all over my house to accomplish exactly what you're trying to do.

Good luck and let us know how it goes!


Thank you. I'll give your suggestions a try and let you know.

1 Like

Hi again. As you noticed I'd already done your step 2, so I performed step 1 and sure enough all the buttons seemed to be responding as they should. Interestingly, buttons 1 and 4 only send pushed messages, while buttons 2 and 3 send both pushed and held/released messages, but this is OK as it is buttons 2 & 3 that should perform the dim up and dim down function.

So to step 3. I deleted the Button Controller 5.1 app and recreated it from scratch. And, after that everything worked perfectly!

I will take a look at ABC as well when I get time.

Thank you very much for the advice.


Great! Glad to hear it is now working as desired!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.