ZEN30 800LR Double Switch

I have a C7 Hub Running Platform

I just got a ZEN30 800LR switch to replace an older 700 series one that died (it failed internally somehow and dimmer didn't work.. unrelated to hubitat).

So I wired it in and the physical buttons both work, and I paired it with my hub after excluding the old one and removing it first... I can control the light with the dimmer switch from the hub web interface, but the child device that controls the fan only works if I push the button, the hub will not control it. When I did the pairing it was identified as "Generic Component Central Scene Switch"

In the logs I can see it report every time I press the physical button to turn the fan on or off so it must be getting info from the switch, but if I try to control it digitally nothing happens.

I have tried pulling the air gap button to reset it, and I've tried rebooting my hub also.

Exact same questions and solution here:

Here is my comments about the beta patch driver: ZEN30 child device questions - #3 by jtp10181

Oh, interesting, I specifically searched the existing posts first and that one did NOT come up in the results ... maybe because I searched "ZEN 30" instead of "ZEN30"... will read and see if that fixes it for me.

1 Like

It fixes it, no if needed :grin: