Z-Wave Wall Switch Developer Question

I got my Hub up and running, My first project is to port my DTHs written for SmartThings. Starting offf, I’m porting my GoControl Wall Switch and have ran into a slight hurdle.

Original Code:

So far, I’ve:

  • Added the Pushable Button capability.
  • Changed “physicalgraph.zwave” to “hubitat.zwave”

My only thing is getting the event’s button visible to the button controllers App. I’m believing the issue is with the line:
createEvent(name: “button”, value: “pushed”, data: [buttonNumber: button], descriptionText: “$device.displayName button $button was pushed”, isStateChange: true)

I’m believing the issue is likely in what data is specifically is passed to Button Controllers.

2 Likes

Our button implementation is a little different that what you might be used to. Load up our virtual button, then you can see the commands and attributes that it uses and those that our apps are looking for.

Where can we get the code for the virtual switches and other virtual goodies?

I posted our “button” implementation here:
https://community.hubitat.com/t/hubitats-button-implementation/283?source_topic_id=255

1 Like

And I get the typical don’t have access message.

You need to get invited to that section, I don’t know what the criteria is, @bobbyD

I have lots of buttons, so many in fact that I needed two Lutron Bridges to run everything...

1 Like

I would also love to see some of the source code for the native drivers/apps, purely as examples of how the platform’s API differs from ST. Without documentation, examples are the next best thing!

1 Like

The criteria is simple: if someone is interested in joining the developers group, he/she needs to ask @support to be included. Referrals are also welcome :slight_smile: @jeubanks and @ogiewon you are now members of the developers group :slight_smile: Happy coding!

2 Likes

Thank you sir!

2 Likes

Thank you very much. And with that my next posting… MQTT bridge

1 Like

Did you ever get the GoControl WA00Z-1 Z-Wave Scene-Controller Wall Switch device driver working? I tried your above code and am unavailable to make it stick.

Have you tried our generic zwave central scene switch with this device?

1 Like

Will try that thanks @mike.maxwell.

Here s the final code:

The above post was an unmodified SmartThings Handler

2 Likes

:grinning:

This driver worked great once I realized I just use an automation to make the button click trigger the lights. Thanks for doing this!

Sorry guys..... I still don't see from the posts above how to get both buttons to work on the Gocontrol WA00Z-1. I just bought this C7 that came with the Gocontrol packaged with it but it doesn't work????? what's up with that?

So far, this is not straight forward. Anyone that can share the steps to get both buttons recognized please share. Thanks

I guess maybe we should start at the beginning?

  • So you were able to figure out how to pair the device?

  • What driver (device type) did it choose when it paired? Go to the Device tab, select this device, and look about halfway down the page.

  • And did you look in the "states" in the upper right corner of that page, and see if it changes there when you push the buttons? This is critical, if it doesn't show up correct here, it won't work anywhere like in a rule or whatever.

From there, you have to decide what to do with the button. Can you describe how/what you expect the button to do, or turn on, or activate?

This is an example of a similar button (so don't make yours look like this) but here are the sections to look at that I mention above.

And by the way, welcome to Hubitat! Ask lots of questions before you get stuck, we will be glad to try and help.

Hey man,

I think I had the same problem as you, where the GoControl switch, once paired, only offers 1 button to choose from, and the "numberofbuttons" in device settings = 1. I saw in another thread, an interesting solution proposed by @mike.maxwell, where you switch the driver to Virtual Button, then manually set number of buttons to =2, then revert back to whatever driver. You can use the custom driver made by @ajpri1998, or I find the Generic Zwave Button controller also works. You will then have two usable buttons. Not sure why this works.

1 Like

Download the Hubitat app