Z-wave routing is just plain weird

Why do so many of my devices want to hop through my Aeotec siren, which is two floors and several walls away from my hub and themselves - including the plug which is in the same room as my hub, separated only by a half-inch plywood shelf? Do some devices take on a kind of celebrity status in a z-wave network?

My ZAC36 valve actuator which is in the basement is a favorite hop for some devices. It is almost directly below the hub which is on the main floor and I would imagine because it is in the open air it gets a really good signal.

1 Like

:face_with_spiral_eyes: I don't think I'll ever be a z-wave graduate!

1 Like

I have an Econet Water valve that thinks its the hub :grinning: It is located in a closet in a basement office and is possibly the furthest away from the hub upstairs. Yet, I have multiple zwave devices within 20 foot radius from the hub that still route through this device. In fact, a ZW15R-1BW outlet, 12 foot straight line to hub prefers to route through this econet device first.

Even though everything seemed to work fine it really annoyed me so last year I excluded the device from the network Eventually other devices found differecnt routes and after a week a re-included the Econet device. Surprise!!! After <n?> days other zwave devices decided that the Econet was the best path to the hub. I learned to live with it. :smiling_face_with_tear:

2 Likes

Doing the antenna mod will result in more devices not routing all together and going straight to the hub...

3 Likes

:confused: :confused: :confused: Say what???

@cdikland
image

1 Like

As long as your mesh is not dropping devices on a frequent basis, do not worry about the exact communication path being followed.

When you need to worry is when devices start dropping off the mesh. I have that situation now. My mesh was quite stable, but when I checked today, about half the devices no longer show connections. Most of the time, about 90% of my devices connect directly with the hub,

Time for me to do some troubleshooting.

2 Likes

Update on my Z-wave issues.

I tried using Refresh and Repair commands on the Z-wave devices that were offline. That is not work. Then I tried rebooting the hub using the internal reboot command. That did not work either. Finally, I decided to pull the plug from the wall and do a hard reset. After a minute, I plugged it back in an allowed the hub to reboot. It came back up with all but 5 devices connected directly with the hub. Most are connected at 100 mpbs. I still have two devices that are not connected: a nearby Aeotec range extender and one of my garage door sensors, an Ecolink tilt sensor. The other tilt sensor is connected just fine. So there is still more work to do.

So if things mess up, a hard reboot should be one of the first things you try.

I hope you shut down cleanly before pulling the plug. Leave unplugged for a few mins the radio to clear. That can help. If after being brought back up you have devices that still aren't routing correctly, I would exclude, factory reset and then re pair those devices.

In certain situations devices will appear to be not connected, have no route, etc, but are fine. Usually once the device checks in and finds its route to the hub the info will re-populate. Or for a mains powered device a refresh on the zwave details should bring it back. The range xtender I would just unplug and replug it. The Ecolink, might just need to activate it a couple times (opening the door) or wait for it to check in.

That is exactly what happened with the two devices that were not working after my reset.

I opened my garage doors. The tilt sensors checked in with the hub and then showed proper routing.

I unplugged my Aeotec range extender and then plugged it back in to another outlet. Then it started working.

Everything is back to normal.

Download the Hubitat app