Z Wave Plus Dome Sensor not updating status

I have a Z Wave Plus Dome Door Sensor that has been acting weird, and I wanted to see if anybody has had a similar issue or could help.

I have a solid Z-wave network, and no changes have been made to it in over a year. Everything has been working great, however my Dome Door Sensor now rarely updates and often shows the incorrect door status. I put in fresh batteries, tried excluding and then including the sensor, and it still occasionally updates the status, but its really buggy.

Any thoughts or suggestions? This is the only device I'm having issues with right now.

A couple of thoughts come immediately to mind.
Have you added any new electronics that may be interfering with the device?
Is it possible that the device is simply feeling it's age?
Are there any errors showing in the logs if you turn on logging for the device?
Does a repair help communication?

Could have worn out the reed sensor in it if you mounted the sensor to the door instead of the magnet. Frequently used doors this becomes an issue on. I have seen first hand. Could also be a misalignment of the magnet.

So this is where it gets interesting. It still registers sometimes, but only if there is a lot of time in between changes in the door being open or closed (30 seconds while the door is left often, etc.

I see nothing else registering in the logs. Magnets are still aligned, and the device shows with a light each time it registers open or closed so I know it’s working. It seems as if Hubitat is not receiving all of the z wave information from this device, if that makes sense.

I had a motion sensor doing something similar a while back. It kept getting stuck on. The LED on the device blinked like it should have been working. The battery level said 99%, the battery voltage on a multimeter was fine, but once installed in the device the battery just didn't have enough "juice" to run the sensor.

I actually removed the sensor from the ceiling thinking it was bad. On a whim, I traded the battery from the sensor I was going to install with this "defective" device's battery, and what do you know, the new sensor wouldn't even blink the LED let alone pair or function with this bad battery.

I don't understand how the voltage is so good, but no current, and why it happened so suddenly. There must be very high resistance somewhere in the battery, but I don't know how that can happen. Anyway, a new battery and all is good.

Just tried a few different batteries, same results. Weirdly, one of my GE switches started randomly turning on and off when I put the battery back into the dome sensor.

Checked the logs and saw this. Could the sensor just be going bad and doing weird things on the z-wave network?


And this switch isn't tied to the sensor in any way (rules etc)? That is odd. And I don't quite know what to make of that error in relation to this sensor.

I guess the sensor could be going bad, but I don't know how it could send these commands to another device. Did you try turning on all logging on this sensor, and see what the logs say?

Anyone else have any idea?

Would it happen to be a sensor like this ....

This sensor of mine started doing VERY similar weird things and after much ado it turned out that it was battery related but I also had to do an exclude and then rediscover / rebuild all the Rules associated with it.
Bit of a pain but sounds worse than it actually was.