Z-Wave Not Working

Has anyone else run into an issue of Z-Wave devices not being detected?

I've just bought the UK/Ireland version of this hub and updated it to

Two devices I've tried aren't on the compatibility list but I've seen a post where someone got one of these detected as a generic shade. Both devices are detected by openHAB so I know they work

I've since tried a brand new Aeotec MultiSensor 6, which is on the list and that's not being detected either so I'm wondering if the radio on this hub could be faulty or maybe it's a firmware fault

As far as I'm aware the radio is built into this model, Rev C-5 and I can ignore the USB stick it came with

I've rebooted it, powered it off, disabled and re-enabled the Z-Wave radio but it makes no difference

Any other suggestions?

The Internal radio is North America frequency. You must use the USB Stick to work with your devices.

1 Like

Do a Z-wave exclusion on the device first and try it again.

Shut down the hub, insert the usb stick then restart the hub
The usb stick IS required for use with UK frequencies for z-wave.
The internal z-wave device (usa) will shut itself down when booted with the usb stick in so the hub will use the usb stick on the correct frequency



Thank you both for such quick replies

I've attached the USB stick as you've suggested Cobra and Z-Wave is now working


Glad I could help.


Zigbee radio is built in as well :+1:t3: