Z-Wave lighting issues

It’s much faster if you use PC Controller (part of SiLabs SimplicityStudio (what a misnomer)) with a USB Z-Wave stick.


Keep in mind that the busier the mesh is, the longer it takes to run an update. Using an empty hub or a USB stick as @672southmain suggested, would be much faster for individual devices.

1 Like

Thanks for the suggestions. I'll probably slog along with the built-in firmware updater on the Hubitat vs purchasing even more hardware. Six devices updated, five to go...

My mesh isn't busy at all. No automation rules, nobody is pressing any switches around the house right now. Maybe the fact that, for some of these devices, it takes multiple hours to "transfer firmware" -- files that are only a few hundred kilobytes -- is further evidence that my mesh network is extremely weak. Not feeling too hopeful at this point, but gotta try everything I suppose.

Absence of rules is only a small part of the network being busy, and usually the insignificant part. The unsolicited incoming traffic from various devices is what creates a busy radio environment.


Curious about that.

Currently, I only have these 11 Zooz dimmers/switches/controllers. No sensors, plugs, or anything like that.

My assumption is these devices wouldn't produce any Z-Wave network traffic -- status reporting, polling, whatever -- unless somebody is actively interacting with them. Not true?

Not true, devices can spin events uncontrollably. If enough simultaneous events bombard the radio, the radio quickly becomes overwhelmed, which is consistent with the symptoms you have described. If logging is enabled for each device, you could often see the "bombardment" displayed on Logs page (select Logs from the left menu).


Well, I got impatient and went nuclear: Excluded every device from the hub, factory reset every device, uninstalled every app from hub, did a Z-Wave radio reset from the hub, rebooted hub.

Tried slowly re-including just one device at a time. Inclusion would fail sporadically (timeout) on some devices, leaving them in a broken state: Not added to hub, but device thinks it's included already, necessitating another round of factory resets.

So I went even slower. Just add 1 damned device to the hub, and keep trying (factory reset) til it's added successfully. Once it's added, I try issuing Z-Wave commands (via Hubitat device UI). Just like before, the commands mostly work, but sometimes lag a bit. If I spam them fast enough, things go haywire.

Tried this with several different devices, ones that are just a few feet a way from hub, others that are about 25' away, same results.

These are devices I purchased over a period of a couple of months, a mix of different models (Zen71, Zen72, Zen77) and hardware versions.

It really just seems like my home environment is not Z-Wave compatible or something. Never had troubles like this with Hue or Lutron.

I've had the same issue with some of the Zooz switches and, in my case, mostly due to me being impatient.

My suggestion:

Go to the switch closest to the hub.
Exclude it from HE if already paired.
Do a factory reset.
Put the hub in exclusion mode and do the sequence from the switch.
Re-pair the switch to the hub.
Repeat your testing.

That's exactly what I've done... repeatedly... to no avail.

Is there some even more nuclear way to start from scratch here that I'm overlooking? Factory reset the hub? Sledgehammer?

I think you may be looking in the wrong direction to solve the problem. I assume you have finished updating the switches? I personally, would not have nuke the system you had, it was looking pretty good. The switch may not be able to keep up with overwhelming amount of commands, but you have to ask yourself, would your shock therapy happen in real life scenario?

1 Like

I updated 6 of them. I was too impatient to spend another day updating the remaining 5. My thought was to wipe out everything, and then experiment with these 6 updated devices and see if they worked any better than before. They did not.

I'm curious what you're basing that on?

One of my primary goals was to establish a Group of five dimmers and control the group via button events from a scene controller. That's pretty much never worked. A single button press to toggle the group, and some of the devices wouldn't respond, or would only respond after a very long delay. A few button presses in quick succession and the whole system would become non-responsive for about 30 seconds.

So I've tried progressively simpler experiments: Instead of button events, I tried issuing commands to the Group device directly to the hub. Same result.

Instead of Groups, I tried issuing commands to single devices. That mostly works, but sometimes there are noticeable (multi second) delays. And if I issue commands quickly enough, it seems to overload the system in the same way as a Group.

Absolutely, yes.

In my household (w/ kids), people expect near-instantaneous responses from lighting controls. When that doesn't happen, they spam the buttons.

My gold standard for smart lighting controls is the Lutron Aurora. Near instantaneous response times, fine tune dim adjustments, 100% reliable operation. Maybe that's too high a bar for Z-Wave?

Based on the detais you shared yesterday.

Your experience is terrile. I can only imagine the frustration. I have groups of 10+ Z-Wave switches and don't have the same experience. So I know Z-Wave is capable of delivering to your expectations. I also have 2 little kids and I know their tendency to spam the switches if lights are not instant. Now from where you are, to where you want to be, might require purging some bad apples from your system. Build the mesh starting with closest device to the hub, work your way outwards. Stop and replace any hard to inlclude devices (add a repeater to see if that helps). Don't skip over a device thinking that you'll come back later. Setting up the mesh property pays dividends in the long run.


1 Like

Purging bad apples is definitely what I'm trying to do here -- it's why I decided to go nuclear and uninstall all apps/exclude all devices. If there's some more thorough/certain way of flushing/resetting the Hub, I'd love to know it.

Are the devices powered on even if not included? If you have a defective device it can interfere with the network even when not included. So make sure you only have power to the ones included if you try to find the problematic one(s).

Unfortunately, going nuclear on the hub and
its apps, has no effect on the problems you are having. The exercise of doing so just adds to your angst, making your experience infinitely more frustrating.


Appreciate the concern for my mental state :slight_smile: And I definitely appreciate the help here.

I'm a little confused about why starting over from scratch is frowned upon. It shouldn't take that long to add a dozen devices back, right? And I didn't have any real investment in automations (yet...) so I didn't have much to lose. Seemed like an appropriate troubleshooting step to me.

I noticed that after performing a soft reset of hub and adding just a couple of devices, I was able to do much faster firmware updates. Minutes instead of hours. But as the system grew again to about 8 or 9 devices, updates slowed to a crawl again. Not sure what to make of that.

In any case, all devices have been re-added, progressing from nearest-to-furthest from hub, and all firmware updated. I don't see any improvement. Group operation (of 5 devices) remains as flaky as ever.

If the theory is that there could be one or two "bad apples" in my set of 11 devices that cause the entire mesh to become unstable/inoperable, well, I'm not sure how to identify the culprits?

So, I've definitely experienced "hard to include" (and hard to exclude) devices, where it takes a couple of attempts before the device becomes visible to the hub, or where it refuses to exclude. (To forcibly exclude, I do a force removal from hub, and factory reset on device).

I've also experienced issues where a device seems to think it's included -- flashes green, refuses to re-enter inclusion mode -- but the hub still doesn't see it, and I do the force-exclusion procedure to try again.

At first I perceived this was randomly happening across all 11 of my devices. It happened on enough different devices I it just seemed like general flakiness with the inclusion/exclusion procedure.

But I'm starting to think there might actually just be 3 or 4 particularly stubborn devices that have this issue, and the others are more reliable. And I think those devices were also the slowest to receive OTA firmware updates, too. I'll need to go slower and verify that observation.

That'd be a lot of "bad apples" for such a small batch of devices. Intuitively, it always seemed more likely that a single device (hub) is malfunctioning versus multiple other devices. But I guess I should be open to the possibility and pursue the matter with Zooz.

However, question about

add a repeater to see if that helps

My very basic understanding of Z-Wave Plus / these Zooz Zen7x devices is that each device is effectively acting as a repeater. Not so?

1 Like

That is correct assumption, but, I leave you with my favorite quote from an expert who is part of the company that brought Z-Wave to life:

"Distance between nodes is not always the criteria for adding more nodes in a network. The Z-Wave radio signals may bounce off metal objects like mirrors or appliances and cause two nodes that are only a few feet apart be completely unable to talk to each other due to reflections of the radio signals."

Definitely feels like a lot of voodoo.

Most of my devices are installed side-by-side in multigang boxes, where I'd expect environmental factors (appliances, mirrors, etc.) to effect all devices equally.

But two of my misbehaving devices (= very slow firmware updates, difficulty including/excluding) are installed directly alongside neighbors that seem to be working fine. Perhaps more evidence to support the theory that those devices are simply defective. I'm opening a ticket with Zooz about it.

I've forcibly excluded those 3 devices that I'm most suspicious of, and the early results are very encouraging. I can perform Group operations against the remaining Z-Wave devices in my mesh with pretty impressive responsiveness, and no failures after a couple of hours of tests. :crossed_fingers:

I feel like my situation was difficult to troubleshoot because the electrician did a mass installation of a dozen devices all-at-once (remodel), so I didn't really have a good baseline established. So in defense of my "nuclear" approach, starting from scratch and proceeding slowly, one-by-one, seemed like the best/only way to identify "bad apples".

I imagine that going forward -- if this system proves reliable and I stick with it -- I'll be adding devices more methodically, and it'll be more obvious if/when a newly added device causes instability.

But it still makes me uneasy to hear how (apparently) easy it is for a couple of misbehaving devices to effectively ruin the whole mesh, and I do wonder if other protocols are more resilient.

1 Like