Z-Wave Device Firmware Upgrade Tips?

Does anyone have any tips for updating the firmware on Z-Wave switches? I did one and it worked fine, but now I've got one (Inovelli Red Dimmer, same as the first one I did update successfully) that just won't take. It gets to like 60% and then throws an error.

Device Firmware Updater: ERROR: The device was unable to receive the requested firmware data

I've air-gapped the switch multiple times trying to get it to work and can't get anything to work. I am using the Device Updater App.

This one is in the basement and the hub it pretty much right above it, so I wouldn't think it's a distance issue, but maybe it is?

Just looking for some tips/tricks to make this a bit easier and more robust. I don't really want to move the main hub all over the place, but was wondering if maybe getting another hub I can mesh to and take that around to update firmware?

I am hoping there are other tips though that don't involve buying another hub.

Thanks for any advice you can give!

Some people use a secondary controller or an entirely different network, either of which can be done with a Z-Wave stick and software like Z-Wave PC Controller (or an entirely other system, like ZwaveJs). Basically like another "hub," though a bit cheaper and a bit more difficult.

Keeping things as-is, the only thing I can think of would be to bring the hub as close as you can and consider limiting Z-Wave traffic on your existing network, which in my experience makes things go slower. (Power monitoring devices are probably the worst offenders. I'd almost suggest unplugging or air-gapping anything else to eliminate routing or other possible slowdowns, but the rest of your network probably won't be happy if the update takes very long...so probably not great advice.)

Is it paired with security (S0/S2) or none? If it is paired with security, I have seen people claim that this happens and/or it slows down the process so much it pretty much takes days to complete.

1 Like

No security.

Had the same issue when updating some zooz sensors yesterday. I updated 6 just fine, then 2 were just being stubborn.

Then this morning I tried the two and they went through with no issue.

No idea what happened overnight to resolve the issue.

I've done many updates of my inovelli switches and there were always a few stubborn switches that would eventually go through after a number of tries. Here's my usual list of go to's,

  • power cycle the switch
  • power cycle any switches it may be routing through as well
  • power cycle the hub (shut down and pull power for at least 30s)
  • try and try and try again

I wish it were an easier process. I did my zooz temperature sensors just because I could see them all flooding the network with random reports. All good now. But I'm dreading having to do the other devices.

1 Like

Download the Hubitat app