Z-Wave delay after update

We updated to this morning. Have had huge delays on most of our Z-wave devices since the update. Some delay as much as 20 seconds. Some devices will accept an "on" almost immediately, however the off is either delayed or never appears to execute.
I will ride out a bit to see if things settle.

Have you tried a zwave repair to reset all the routing tables?

Mesh looks fine. Routes look fine. Speed and RTT look fine.

1 Like

Do a full power cycle. Shutdown the hub from settings and then unplug (at the wall not the hub) for 5 mins and power back up and see how things are. (this will clear the radio which a reboot won't do)

Have you done the z-wave firmware update? If you haven;t you will see a z-wave firmware update button on your z-wave details page.


Usually not the first recommended step when general Z-Wave issues crop up after an update, and no devices have been changed/moved/removed. As @rlithgow1 recommends, better first step is shut down hub, unplug from wall, wait a minute, plug back in. The "wait a minute" allows time for the Z-Wave radio to reset so you can start the hub up Z-Wave fresh. :slight_smile:

1 Like

Hi Rlithgow.
Firmware is the latest release that Bryan provided a couple weeks ago, 7.18.1.
We had already powered the device down, and back up, prior to a repair. I try to let the
mesh deal with itself.

1 Like

Hi Danabw.
Thanks.. I probably should have indicated steps I performed in the initial post.
Already done this...


1 Like


Well thanks for the feedback, where i come from (smarthome wise) is a Fibaro homecentre and i can assure you from personal experience that firmware updates for the HC (e.g. restarting the master node) sometimes caused the routing tables to go wonky. If that is different for the Hubitat im open to learn, but frankly, rating one advice over another in a scenario where we all chip in to help someone feels a bit strange to me to say the least. But then again, hey, im the newbie, not an ambassador.

We all are always learning, of course, including myself.

Just providing feedback based on experiences w/HE and comments from staff...a full Z-Wave repair is rarely necessary these days, and generally not going to be the first call when an event like this one occurs. The results from a repair can take days and longer to appear, and the effect of a full shutdow/wait/reboot w/HE can sometimes be quite magical (in a good way) and immediate in its impact, so it is a quick and simple "good first thing to try" as they say. :slight_smile:

Sort of like my advice to my family - "Don't come asking me about problems w/your 'fill-in-the-blank' device unless you have at least tried rebooting it once. And that includes the toaster!" :wink:

1 Like

I would have asked if it was plugged in before “rebooting the toaster” but hey :joy:…. That’s all about personal preferences.

On the serious side, I have read the linked topic of bcopeland before posting and was aware that repairs in more recent zwave devices is a rare necessity, but judging from the issues @jsprince3 described it sounded to me that zwave commands were either delayed or not at all received. Routing in that case is an issue to consider.

All good as far as I’m concerned

1 Like

The next time that happens you will be fined. :wink:

An unlikely coincidence, but in some cases a low-battery FLIRs device can cause problems on a mesh...I had a Honeywell Z-Wave thermostat w/low batteries take my hubs Z-wave mesh down once coincidental w/a beta testing period, and it took me a couple days to figure out it wasn't the beta release, it was the thermostat. So maybe check batteries on Z-Wave devices...

And, as you note, things might actually just clear up on their own. Since the reboot didn't help and you've done the repair, the most effective medicine may be to do as you say and give the mesh some time to adjust to whatever has upset it.

One thing - on the shut down you unplugged waited at least a minute before plugging in again, right? Just want to confirm...

1 Like

Devices I am having problems are all wired.
Will wait until this evening.. If I still have problems, will dig in further.
This post was more for information that I saw a problem after FW update.

Thanks All!!

The devices I was having problems with were all wired as well. The issue was that the battery device itself was low, which cause problems on the mesh which affected my light switches etc.

Might be a coincidence, but you also might have a device that is just about ready to fail.

I still have a few of the older GE/Jasco Z-Wave devices in my house. When they fail, they start "chatting" gibberish and cluttering up the mesh. When I see this, I look for the dreaded "flashing blue light" and air gap the device until I can replace it.

In all cases, air gapping the flaky device has returned my mesh to normal.

1 Like

If it continues ask @support_team to look at your engineering logs

Get those things excluded so anything routing through it can find a different path :slight_smile:

1 Like

This ^^^ :slight_smile:

I believe, instead, it’s to allow all the capacitors to discharge so that all power is lost. That causes the Z-Wave radio to reboot when power is restored. The Z-Wave radio remains powered, unreset, and unrebooted when the hub reboots. It’s its own little processor.


Yes, your description is technically accurate, while mine is based on witchcraft. :slight_smile:

Thanks for clarifying the details...I'm gonna copy that and use it when you're not looking. :wink:


If it involves RF (like Z-Wave does) it's Black Magic...witchcraft is only reserved for special reboot sequences!