“Your application is not set to allow background location information.”

Anyone else having trouble getting geofencing to work for your iPhone even though Location Services is set to Always Allow? The Hubitat iOS app gives me the error below on my iPhone despite everything I’ve done (update iOS, uninstall reinstall the Hubitat app, confirm Location Services set to Always Allow in both the Privacy Settings and the Hubitat app.) Strangely, my iPad has none of these problems.

Edit: The iPhone does show as present in the dashboard and is correctly located in the geofence map. Also, upon launch of the Hubitat app on my iPhone, geofence debugging messages do pop up indicating that it sent ENTER message.

That means that your iPhone is only set to allow the use of the device's location while the app is open. So, it will not update your location when you are not directly looking at it. This should be modified in the device privacy setting to allow for background location. Otherwise, you would have to open the Hubitat app to get it to recognize you as home or away.

Here's an article on how to change it.

Thanks Ryan. Maybe I’m missing something then. I’m still getting the notification even though those are set:

HOWEVER, geotracking did toggle my home lights when I drove down the street and back with my iPhone and the Hubitat app in the foreground, so I’m wondering if the messages are in error.

In terms of rule functionality, turns out the above warning messages are erroneous.

My simple lighting rules to turn off all lights when we leave and turn on all lights when we return based on iPhone geolocation, work just fine (without needing to have the Hubitat app actively running).

Not sure why the warnings keep firing upon Hubitat app launch and upon exiting the geofence. But at least the fun, cool parts are working! :slight_smile:

For iPhone, it looks like “Background App Refresh” under Settings, General, Background App Refresh is required to be turned on for HE’s Presence trigger to work reliably (or at all?).

I found this out with my new rule that was supposed to unlock my new Schlage Connect Zigbee smart deadbolt lock upon arriving home. The rule was unreliable, but looking at my Hubitat dashboard the reason seemed to be possibly that my iPhone was frequently ‘Not Present’ even though I was home. Shortly after I turned Background App Refresh on, the iPhone became present in the dashboard and the Schlage lock rule triggered!

This is all very preliminary, but I’ll update the thread once I have more data to confirm my hypothesis.

1 Like

Changing this general "Background App Refresh" setting to on did the trick for me, in terms of stopping the warning mentioned in OP.

I was tearing my hair out trying to figure out why it kept giving me the "application is not set to allow background location ..." warning, even though I had changed the Hubitat app specific settings to allow background app refresh, just as you have shown in the screenshot in your post above.

For anyone else like me that happens upon this thread searching for a solution to the same problem, it turns out that the reason the "Background App Refresh" selection in the Hubitat app settings is greyed out (like on Maclabdoug's screenshot from Aug 17 in this thread), even though the switch is turned on is that the universal Background App Refresh setting (under settings > general) ALSO has to be turned on.