Xiaomi Roborock Integrations/Automation Ideas?

I am tossing up between getting a iRobot i7 or the Xiaomi Roborock S5 Max, and I am leaning more towards the S5 as it has marginally better review and a fraction of the price compare to the i7.

However, it seems I am unable to find anything in terms of setting up automation with HE. Ideally I would like it to start a cleaning task when HE goes into Away mode. This could be achieve with the iRobot via IFTTT.

Anyone has done it with a Roborock, or any suggestions how I could achieve automations?

I've been looking at the Xiaomi one, I live in China and here they are very affordable. I did find this:

So there is a way, which means a driver COULD be written, but as far as I know, none have been written yet. IF I buy one, I will write a driver if no one else does, but if someone else do write a driver, I'd be very happy :slight_smile:

I have an S5 and had to use the google assistant relay to integrate it into my automations so is still cloud dependent.
I did try to do it through Mi Connector but my vacuum was the international model so can't connect to the China mainland server.

I didn't know this was a thing, great to know, living in China I've never thought about them making this difference.

This is one thing I haven't brought over to HE yet, but I'm using the Mi-Connector app right now on Smartthings to integrate my Roborock S6. I did have to briefly install a hacked version of the Mi Home app to get the vacuum's token. Once I had that, it integrated right away. I would expect the process to be the same on HE but haven't gotten around to trying it yet. Maybe it'll be a good snowstorm project for tomorrow.

1 Like

I'm using Google Assistant Relay to trigger an S5 to start cleaning when we leave the house. It works fine but it'd be nice to have a more direct integration.

I've been really impressed with the S5 and it's got the partners approval too.

This is sort of on my todo list but not really. At the end of the day you don't need status and you can start it from GAR on a schedule or event. I'd rather first tackle my GMG and then my Anova so that the house can tell me when my cooks are done.

I'd recommend just using Google Assistant Relay (v3) with obie's v2 driver and call it good as others have suggested.

FWIW I have the Roborock S5 and am pretty dang happy with it. I just use the Xiomi native app which is pretty good, but not integrated with anything.

That said, if you want me to try some things out with mine, let me know. So long as I don't completely mess up my Roborock, I'm happy to try things out. (You know how long it took me to convince my partner that we should get one?)

Anyway, happy to try to help.

I have the Roborock S5 Max and I use Mi Connector on Hubitat. I had used it on SmartThings and simply migrated it all to Hubitat. Works great. I can control almost every function on the S5 Max. I also added a virtual switch and a bunch of custom routines to Alexa to start and stop vacuuming and return the vacuum to the dock. Now I can say "Alexa, start cleaning, start vacuum,...) to get things going.

The author didn't have the S5 Max (model s5e) added so I had to edit his docker file to get it added. I told him and he might have added it now though.

Interesting, can you elaborate on how to do this? Do I need to have a Mi Hub?

Search works decent on the forum :wink:

Looks like for robot vacuums this is definitely the way to go.

Looking through this current list of very diverse and useful compatible products with the Miji hub, Iā€™m very tempted myself. I have been extremely happy with the Aqara hub. It takes these inexpensive Xiaomi devices and makes them 100% solid. Absolutely no drops, no faltering. So very much worth the effort and minor investment.

Do you think the S5 Max is worth the money? Considering getting one as like the mop features and we have all hard floors downstairs and carpets upstairs. Did you get it working with Hubitat? I'd like to tie it to HSM modes to trigger cleaning :slight_smile:

I like it. I haven't used the mopping much (just twice) but it worked decently when I did and got a lot of dirt.

I have it working great with Hubitat. I use Mi Connector running on a raspberry pi. I can schedule it and control it from Hubitat, I was also able to add to Alexa using Hubitat and use routines so I can say "Alexa, clean house" etc.

I'm not sure I'm a good judge for you, as I have not yet used the mopping feature. But I can tell you the S5 now lets you make "rooms" in the app and you can clean by room. So, theoretically you could pick where to mop and not mop. However, creating the rooms is not very easy to do through the app. It seems besides some water capacity and some mopping functionality, it's not much different. So, for me, not worth it. I do have areas which I would mop that are different than those I would not mop all on the same level, but unless they've done a better job on the MAX to differentiate those, I don't think it will help. And since it's the same app, it's probably the same difficult experience, especially if your rooms are not perfectly square.

I did not hook mine to HE as I did not want to buy the connector.

I hope this helps!

Hey, I'm interested in setting this up as well, do you need an additional xiaomi hub in order to use Mi-Connector with the S5 Max? How do you set up your raspberry pi?
Thank you very much

No. You don't need a xiaomi hub (and I don't have one). You do need a server to run mi-connector and most people use a raspberry pi for that.

Instructions are here:


You can create no-mop zones (similar to no-go zones) and it won't make those areas. Not sure why you won't create rooms though. That's very useful

1 Like

So Docker, Mi-Connector, MariaDB is running on RPi, the token registered successfully and the Roborock is updating battery status to MariaDB.
Now I am stuck in die Mi Connector App on Hubitat, it is not getting the device.

The log on the Mi Connector (RPi) shows:
2020-06-07 10:33:10 error Get Data from ST is failed....

This happens every 4 Seconds, so the Hubitat/ST App seems to communicate with the RPi and is trying to get Data. Is there a different App than v.0.0.34 specifically for Hubitat? Do I need the Access Token for the MiConnector App on the RPi to communicate with the Hubitat App? Am I missing drivers?
I don't really have an angle right now, maybe you have encountered something similar. Thank you for your time.

I didn't say I won't create rooms, I said it's difficult to do in the app, especially if your rooms/zones are not perfectly square. Also, the number of rooms you can create is limited to like 10 or something so you are limited in what you can do with that feature.

Hey mate, how did you get the token from your S5Max?

I have tried a few methods found on google but I can't seems to find one that work. Can you link the instruction page that you used?