Xiaomi devices - are they pairing / staying connected for you?


#61

:rofl:


#62

Thanks again for all the detailed reports on your continuing tests to find a suitable repeater for all your Zigbee devices.

I looked through the customer reviews on the SYLVANIA plug of Amazon’s (South of Wall) site, and saw this one interesting comment from Jan 8 2018:

There are two models of this device; the 72922 and the 72922-A. If you receive a 72922 , it will readily be recognized as a Sylvania Lightify outlet. If you receive a 72922-A, depending upon how “smart” your hub is; you may receive a pairing error. In my case, I have a Wink 2 Hub. Pairing a model 72922-A as a Lightify outlet resulted in a pairing error, but when I checked the hub’s Home page, it was registered as a “Generic Zigbee Light Bulb.”

Do you know which model you have, and also how easily did it pair?

Indeed, and the only information I’ve found on so far on best or better choices is - as I mentioned above - higher channels don’t work well with SmartThings brand Zigbee devices, and generally channel 26 is not a good choice as some devices just won’t work with it.

Speaking of channel choices, when I got home, 8 hours after changing my Hubitat’s Zigbee channel to 13, I found that none of my Zigbee devices seemed to have changed over to the new channel.

I got tired of waiting, and started with the least invasive method of getting them reconnected. My Sengled Classic smart bulbs just needed me to press the configure command button in the Hubitat device details page for each of them, and then they were working fine.

However, for all my Xiaomi devices, I found that short-pressing their reset button to get them reconnected only worked with about 1/3 of them.

For the others, the LED flash sequence on short-press of the reset button told me that they had lost their connection. I had to put the Hubitat into Discover Devices mode and then long-press the reset button (same as what’s done to pair them). Keeping either the Log or Zigbee Log window open helped for me to know whether they had reconnected.

For most of those devices, they were reconnected on the first long-press of reset button, but there were a few devices that took a number of attempts to get recognized again, the worst ones being my 2-button Aqara Wireless Smart Switches (model WXKG02LM). They weren’t easy to pair in the first place, so no surprise there.


#63

So still disconnecting with all my wifi AP on channel 11 and zigbee on 12. I changed the zigbee channel to 12 this morning and so far the two Xiaomi sensors and three other devices found the HUB. Wonder how long before everyone else join the party.


#64

Try Zigbee channel 13 and let everyone know how it goes.

If you’re not keen on my “lucky” 13 theory :wink:
Here’s a discussion along with some sensible advice from @JDRoberts


#65

so I made the change to channel 13 3 hours ago and still no device is reporting in. How long does it usually take?


#66

It can take up to 24 hours or longer depending on the device. It usually should be less than 60 minutes for most devices depending on their reporting frequency.

I would NOT recommend disabling and re-enabling Zigbee Radio nor rebooting immediately after changing the channel. You need to just give it time to update all the devices that the channel has changed.


#67

Thanks @patrick. I changed the channel back to 12 and a lot of the devices started reporting immediately.


#68

Will update my previous post to reflect your advice.


#69

Just received my second Xiaomi Aqara leak sensor today. I can confirm that once again, pairing was absolutely no problem using the following sequence:

  1. Hold pairing button for 10 seconds and release
  2. Wait 3 seconds, then double short-press pairing button
  • Sensor shows up with “Initializing”
  1. Wait 3 more seconds and double short-press paring button again
  • Sensor successfully paired and also automatically selected the Xiaomi driver (already installed).
  1. Saved and tested. Wet detected immediately.

I’m going to test this one in the basement to see if it drops off. It’s actually not far from the hub, maybe 25 linear feet.


#70

As Xiaomi devices are designed to work with a Xiaomi hub, I wouldn’t be surprised that they don’t reconnect to the Hubitat after a change of Zigbee channel. Some manual “prodding” may be necessary (as I found I needed to do in my circumstances).

That article on MetaGeek Support by Joel Crane that I linked to a few posts up makes it clear that for best performance of 2.4GHz WiFi and Zigbee Mesh networks in the same space, some planning and testing of an optimal choice of channels may be necessary.

I figure that if I can determine which channel works in keeping all of my Zigbee devices connected all the time, it will be worth the effort.


#71

I have the 72922
The hubs (SmartThings and Hubitat) see the device very easily but pairing correctly was a bit hit and miss. You have to make sure the plug functions and reponds to commands correctly. If it does not pair correctly it initially appears correct but does not respond to commands or sometimes only partial commands (ex. on but not off).
To pair it you put the hub in discovery mode, hold the button and then plug it into the wall and keep holding the button until you hear a click. The hub should see it right away. (it may take 3-4 attempts to pair correctly)
I would still like to let this run 3-4 more days to confirm nothing falls off. Usually unplugging and replugging the device back it is fine but once it did fall asleep when I put back in. Similar to the Xiaomi to wake it up I had to put the hub in discover mode and with the plug still plugged in just push and hold the plug button until it clicked and the plug woke up. I had to the same to the Xiaomi devices I had running through it at the time, With out having to re-pair them. They may have come back by themselves but I want to run a week long test with out touching them to see if everything stays connected.
I wonder what range of channels the Xiaomi hub uses.

I have also noticed 99.9% of the time devices when pairing will always go to the repeater device versus the hub. The key is making sure they go to the repeater you want.

DH for the SYLVANIA plug


replace physicalgraph with hubitat
the generic zigbee plug or switch DH would work but always leaves the plug status as unknown and it would not log any events (maybe due to not pairing correctly).


#72

I’m not sure if this has been mentioned yet, but Xiaomi devices can be added by monitoring the Zigbee logs and manually entering the DNI using the Add Virtual Device option.

I have used this in cases where the device fails to initialize.


#73

Just to update on the progress. My hubitat is back to running on channel 12 and all 3 Ubiquiti APs are running on channel 11. Both Xiaomi sensors have been performing great with hourly updates. It’s been a week and things seems a lot more stable. fingers crossed :slight_smile:


#74

I never understood if my Ubiquiti APs should be one the same channel or different channels. Right now they are spread out which makes Zigbee difficult.

I have 2 AP Pro (basement and 2nd floor) and one Mesh (will mount outside once warmer)


#75

It’s been a bit over a week, and all my Xiaomi devices have remained connected with one exception: My two round “original” Xiaomi Buttons.

I have been working on an update to the SmartThings device handler code, so as part of that testing, I’ve been going through the process of pairing those buttons to SmartThings. They pair easily and quickly, always on the first or second instance of putting the button into pairing mode.

However, they will no longer pair with my Hubitat. I don’t even see the Zigbee ID appear, and no related entries in the Zigbee log.

Thinking it may be related to my choice of Zigbee channel 13, I powered down my SmartyThings hub, disabled the 2.4Ghz radio of my WiFi router, and tried pairing the buttons with the Hubitat Zigbee stick set to channels 11, 12, 15 (same as my ST hub), 25, & 26 (my Hubitat’s previous channel). None of those channel changes worked. I have probably long-pressed the reset buttons over 150 times by now, all in vain.

So I’ve contacted the folks at Hubitat to check whether there have been any recent changes that may have affected Zigbee pairing.

On a positive note, however - after changing my Hubitat’s Zigbee channel back to 13, all of my Xiaomi devices resumed their connections without the need to re-pair, and of my other Zigbee devices, there were just two Sengled Classic bulbs that needed to be re-paired.


#76

Lucky 13! :wink:
Both my Xiaomi Aqara Leak Sensors are still connected on Zigbee Channel 13. Not a single issue.


#77

after about a week on channel 20 all of a sudden at pretty much the same time a lot of my zigbee devices fell off. not just the Xiaomi but all of my plugs as well and a few other devices I assume due to SmartThings hub also on channel 20. A few other zigbee devices did stay though.
I contacted SmartThings support and apparently only they can change the zigbee channel. They changed it to channel 22 for me.
I also went through every zigbee channel as a test and tried to pair a device on each channel 3-4 times to see which channels saw the device right away if they didn’t see it after 3-4 attempts I moved on to the next channel. I did this with a water and a motion sensor. My best results were on channels 14,15 and 20 but channel 20 still gave me the best results.
I preformed this test a few times and went back and focused on the 3 main channels and tested again.

I also moved 2 more plugs to Hubitat to test with. An iris 3210 (with the zigbee and zwave in it) and a SmartThings plug (F-CEN-APP-1)
So I divided all my Xiaomi devices into 4 groups (the iris plug, SmartThings plug, SYLVANIA plug and directly to the hub) I left the Orvibo out as they are at the far edge of my test area really just testing with my SmartThings Arrival sensors which I paired through the Orvibo outlets.

I have also turned off most of my 2.4 wifi
during the setup I noticed that the plugs if left unplugged to long would not always come back by themselves. I had to discover devices and then push their pairing button and they would then come right back (no need to remove and repair) and if the devices that were paired through them did not come back right away then do the same just go into discover devices an push their pairing button and they appeared right away. (again no need to remove and repair) The interesting thing is they would always stay with the router/repeater devices they had initially been paired though. (unless you removed them and went through the entire pairing process again)
The worst plug so far is the SYLVANIA but once it pairs correctly it does work. even after it was paired correctly when I left it unplugged for awhile and it would not always come back and function correctly right away. I had to go back into device discovery and push the pairing button. Sometime I had to do this a few times until I saw that it’s on/off was functioning correctly and then it worked (had the same issue as when I initially paired it).

So as far as using plugs as repeaters goes I would recommend putting them on a battery backup supply in case of a power outage may cause issues.

Will see how each plug type fairs


#78

So I have about 12 motion sensors and 6 temp/humidity sensors which I migrated to Hubitat and they all stayed connected without issue for about a week. Since they stayed connected that long and were working locally I decided to move the rest of my contact and moisture sensors over from ST which consist of ST contact, Visonic Contacts and Centralite Moisture.

Once I did this my Xiaomi devices started to drop off. I’ve since then changes my WiFi to channel 1 (used to be auto) and changed my zigbee channel to 25. All my non xiaomi moved over to the new channel ok but my Xiaomi only a handful of them seemed to have moved over and are reporting events.

Is there away to manually rejoin the Xiaomi Sensors without having to remove and repair them?


#79

Follow the steps here:


#80

Basically just put the hub in “Discover Devices” mode and follow the same steps for pairing, but without removing them from the Hubitat’s device list.

There’s no feedback that the device has rejoined in the “Discover Devices” window, so I would recommend also opening up another browser window with the Zigbee logging page (found in Settings -> Zigbee Information --> Zigbee Logging). When the device has rejoined, there will be Zigbee log entries under its name.