Xiaomi / Aqara ZigBee device drivers (possibly may no longer be maintained)

Im pretty sure that's not the problem, because with other aqara sensors I have the same problem (>60% battery). Tho' im not going to fumble around with those anymore. I don't want those kind of readings for those aswell. :slight_smile:
Thx tho.

Have you tried removing the driver, deleting the code and pasting in a fresh copy? Maybe something is incomplete. It's unusual but it's happened to me with other code.

Not sure your experience level. Make sure you grab the RAW code, delete the old and paste in new, not on top of the original.

I honestly can't remember how I pasted the code, usually I take the raw code, paste as plain text. Just to be sure and rule it out I did what you described to no avail...

Trying to follow what you are asking. If I’m reading right this may answer your questions.

After you set the offset and save the settings I don’t think it will reflect The changes until the next time the device reports in. So make the change, blow on the sensor and it should report right away with the proper offsets applied.

The driver displays in C or F based on the location setting. You can change it in under settings on the hub. Again the change won’t be reflected until the next time the device reports in. This change also affects all devices that rely on it.

Hopefully that helps.

That explains the changes made only when the sensor updates.
Im trying to get the sensor in proportion but as the max for pressure is -+2000 i have to do this in 2 attempts.
With blow you mean to force it to update... how would one do this for example?

@veeceeoh @guyeeba
I've got the xiaomi smart plug ZNCZ02LM
I don't mind helping you guys test if you want to do a proper driver for this.

Here's the device details when I tried to pair with with HE

Note HE automatically choose the driver Hubitat/Aqara QBKG11LM-QBKG12LM-LLKZMK11LM.groovy at master · guyeeba/Hubitat · GitHub for me to use. And also using that same driver, I can trigger the on/off of that smart outlet. So it looks like there's not a lot of work to be done. Could probably be supported by that same driver.

The sensors only report in when there is a significant change. Just walk up to it and blow into the sensor. It will detect a change and report in. That's the quickest way to get it to update.

Unless you're using firmware 2.0.4 or earlier, you most definitely should not enable this option. Enabling it on a hub with firmware 2.0.5 and newer will result in incorrect reported values.

The virtual temperature sensor is a completely different device driver, so I would avoid making comparisons in functionality. Let's just focus on what's making the Aqara Temp-Humidity Sensor device driver apparently ignore your offset values.

This is correct. Changes to the offset values are only applied to subsequently reported values, not the last reported values before the offset(s) are changed.

I can also confirm this. However, the device details page won't display the units, just the value(s). You can see the units displayed either in the Events List for the device, or in Log Message output (if that is enabled).

I don't understand what you mean here - can you please explain what you're trying to do?

Yep, literally blow on it with your warm, humid breath. This is by and far the best way to check if a Xiaomi / Aqara Temp-Humidity Sensor is working, paired, and reporting.

1 Like

Ah literally. I wasn't sure... blow has so many meanings. :wink:

1 Like

I think the offset has a limit. For instance 200 for the temperature, 2000 for the pressure. Being in the 6000's with pressure this might take a few tries.

Thank you for all the clarification. I will apply all and blow the sensor back to normality, with my warm humid breath. :slight_smile: Again thanks.

Since I was the person who ported the code from the SmartThings device handler to a Hubitat device driver I can tell you that there are no limits to the offsets.

The pressure sensor in the Aqara Temperature-Humidity Sensor is designed to report on atmospheric air pressure, and the default unit (if not set by the user) is millibars.

As explained on Wikipedia, the highest / lowest atmospheric air pressure values ever observed are 1084.8 mbar / 870 mbar, respectively.

You haven't mentioned what unit you are using, but for millibars as well as all three other choices, (kPa, inHg, & mmHg,) a value of 6000 would be completely out-of-bounds. The only unit that would have real-world values of over 1100 would be Pa which equal to mbar * 100. But the device driver does not have a setting to post pressure value events in the Pa unit.

Are you trying to use the Aqara Sensor to check HVAC ventilation pressure? The sensor is not designed for that and it will not give accurate readings when used for that purpose.


Not so. This is in open space, not in any special condition. As I said fumbling around wasn't the best tactic, hence I got stuck with a 6000mbar-->

That would have been a better way to go definitely. :slight_smile:

The good news is that I'm getting slowly but surely back to normal values with each offset change (blow-triggered). I know this is not the way offsets work but i'm only a few milli-bars away from the usual to be expected value. The other values aswell.

...thank you for the help (@veeceeoh @SmartHomePrimer @gavincampbell ) and sorry for the fumbling which got me in that mess in the first place...

1 Like

I'm having issues with pairing a WXKG01LM. Getting this in logs:
sys:12019-05-23 21:03:14.739 infoCreated Unknown Zigbee Device

sys:12019-05-23 21:02:49.136 infoZigbee Discovery Stopped

sys:12019-05-23 21:02:11.663 infoInitializing Zigbee Device 00158D000255D2CE, E28E

sys:12019-05-23 21:01:49.129 infoZigbee Discovery Running

and I've have installed device driver

  • Xiaomi "Original" Button - model WXKG01LM
  • Device Driver for Hubitat Elevation hub
  • Version 0.8.5
    Any ideas?

From the logs you posted it appears a device was created, possibly without selecting the correct device driver. But just seeing the log entries doesn't tell me what happened.

Was a new device added, with the option to name it, in the Device Discovery window?

Also, have you successfully paired any other Aqara / Xiaomi devices?

No new device.
And I have other Aqara/Xiaomi devices; 2 different temp. humidity, a aqara button, Xiomi door/window sensor

Since you've been able to pair other Aqara/Xiaomi devices, I will guess that the pairing process isn't completing before discovery mode automatically finishes. Sometimes it can take a while.

Generally speaking, after a Aqara/Xiaomi device's LED indicates a successful connection, it helps to short-press the reset button every 1.5-2 seconds, which keeps the device "awake" to complete the pairing process. Have you tried this?

The other thing that comes to mind is asking whether you may have reached the limit of 32 ZigBee end devices.


Hello, I've added four Aqara Leak Sensors with out issue however what dashboard template is good to use with the Aqara Leak Sensor? I've tried contact and water and while water gives me the battery level (contact doesn't show anything usable) it give a question mark for the main status. I tried doing a search but didn't find anything that seemed relevant.

No i have not tried that. I'll give it a go.
No, I'm not at 32 devices. Only 13

I have two, one is as you described the other works fine. I returned the one that doesn't work. The part numbers are the same but the one that works has a black water drop on the cover and the one that doesn't work has a grey water drop. I tried pairing the bad one a dozen times using the 1-2 second button pressing, battery resets etc, the same every time.

In my experience, the leak sensors need to be triggered to get an initial status. The ‘water’ template works for the dashboards.


Download the Hubitat app