Xiaomi / Aqara ZigBee device drivers (possibly may no longer be maintained)

All I get is a load of code displayed.

This is what I see, but I have a lot more zigbee devices than shown.

Parent child parameters
EzspGetParentChildParametersResponse [childCount=3, parentEui64=0000000000000000, parentNodeId=65535]

Child Data
child:[Garage PIR, 91FE, type:EMBER_SLEEPY_END_DEVICE]
child:[Office door, 6862, type:EMBER_SLEEPY_END_DEVICE]
child:[Garage door, F303, type:EMBER_SLEEPY_END_DEVICE]

Neighbor Table Entry
[Guirlande , 0D0D], LQI:46, age:7, inCost:7, outCost:0
[Kitchen bulb, 18F5], LQI:252, age:6, inCost:3, outCost:3
[Vero Bed, BA68], LQI:252, age:4, inCost:3, outCost:7
[Garage workbench light , BF41], LQI:237, age:4, inCost:5, outCost:3
[Bed LEDs, F771], LQI:92, age:7, inCost:7, outCost:0

Route Table Entry
status:Active, age:64, routeRecordState:0, concentratorType:None, [Kitchen bulb, 18F5] via [Kitchen bulb, 18F5]
status:Active, age:64, routeRecordState:0, concentratorType:None, [Garage workbench light , BF41] via [Garage workbench light , BF41]
status:Active, age:64, routeRecordState:0, concentratorType:None, [Kids Bath TH 2, C177] via [Vero Bed, BA68]
status:Active, age:64, routeRecordState:0, concentratorType:None, [Vero Bed, BA68] via [Kitchen bulb, 18F5]
status:Active, age:64, routeRecordState:0, concentratorType:None, [Kitchen door, 7BD1] via [Kitchen bulb, 18F5]
status:Active, age:64, routeRecordState:0, concentratorType:None, [Guirlande , 0D0D] via [Garage workbench light , BF41]
status:Active, age:0, routeRecordState:0, concentratorType:None, [Bed LEDs, F771] via [Kitchen bulb, 18F5]

Yep. I used to get the same. Not anymore.

It works on/off for me. Haven't bothered to figure out why. Maybe on my hubs it only works for a while after a reboot? Not sure.

But a few weeks ago it wasn't working... Last week it was working... Tried last night, wasn't working again.

has anyone had false notification issues with their aqara contact sensors? I'm having an issue here: False notifications from contact sensors?

I'm wondering if it is more sensor related than something in the Notifications App. I'm comparing and it seems the multiple rapid open/close in the logs only happens with that sensor.

These "harmless" errors are from a type of non-useful message typically occurring during the pairing process that the driver isn't coded to handle.

I will be updating the drivers to ignore that type of message without throwing an error. Thanks for the report!

Yes, I've seen the same, in past when I changed my hub's ZigBee channel, though a couple of Xiaomi / Aqara devices managed to change over by themselves. Manually rejoining the devices sped up the process of bringing them all over onto the new channel.

One thing to realize is that a repeated value will not generate an event. Only when a newly reported value is different from the previously reported value will an event be generated.

Otherwise, the frequency of temperature / humidity / pressure reports is entirely set by the hardware, and completely out of the control of the device driver as the sensors won't accept any normal ZigBee commands to adjust reporting.

Also, I can say that in my experience, some ZigBee Repeater devices drop messages from Xiaomi / Aqara devices, despite allowing those Xiaomi / Aqara devices to remain connected to the ZigBee network. This issue can even manifest in only some messages being dropped, particularly when a number of messages are sent rapid fire, as is the case with the Temp/Humidity sensors, which normally send temperature / humidity / pressure reports at the same time.

I notice from your post with the output from getChildAndRouteInfo that for example, your "Kids Bath TH 2" is routing via a "Vero bed". I don't know what the "Vero bed" is, but if it's not in the list of reported compatible routers/repeaters in the OP of my other thread here, I'd be suspect of that router device possibly dropping some of the Temp/Humidity sensor's messages.

The multiple rapid open/close issue has been mentioned before, by @gavincampbell, here.

I explained some possible reasons for this in the next post, and after that I tried some modifications to the code to filter out extra unnecessary open/close events. @gavincampbell came up with a better solution that seemed to work, but I never had a chance to roll it into a full release update of the driver code.

It sounds like I should revisit that modified code...


Thanks for that, I picked up half a dozen of the Tradfri outlets from IKEA. They've already helped with some of the Cree bulbs as well.




The Hubitat community is just a wealth of information.

Strangely enough Bath TH 2 is the new sensor which is working well and "Vero bed" is an Osram Smart+ socket. The sensor which is updating slowely is called Bath TH but only on humidity the temp probe is working fine

Oh! What is the model of OSRAM Smart+ socket you're using? I should add that to the list of router devices that are known to work with Xiaomi / Aqara devices.

I don't see "Bath TH" in your getChildAndRouteInfo output. I don't suppose you know if it's connected to your ZigBee network through a router device?

osram plug is AB3257001NJ

The faulty device didn't show on the getChildAndRouteInfo so don't know how it is routing, not sure why but a lot of devices don't show on the list despite working fine

r u sure about the 5 sec reset motion? what i see is there is a hardware limitation to 60 sec.

5 second reset only works if you do the "magic dance"



thanks. i missed that

In case anyone is looking saw a great price on the newer Xiaomi motion sensor(9.99-free ship USA) with Lux reading. Mine works amazing with the 5 second reset hack and hasn't fallen off in months.


Good deal. Sold out already though. :slightly_frowning_face:

But, just $1 more at Gearbest with Free unregistered airmail

My problem appears to have been resolved. I had a couple of zigbee lightbulbs that had stopped working, I re-paired both bulbs and the humidity readings started working again! It's really weird as the temperature readings hadn't stopped and we're reacting very quickly but humidity was almost never updating.

Anyway, appears to be OK now.


I previously had these devices, all motion sensors paired with Smartthings and had them fall off quite a bit. Since then I’ve attached them all to the Xiaomi hub and integrated them with HomeKit. On HomeKit using the hub I’ve not had a problem, they are as good as the hue sensors.

Is there anyway to pair the Xiaomi hub to Hubitat as well? It would make some rules easier then exposing all the Hubitat devices to HomeKit for automations.

No integration with the hub in hubitat currently. But anyone could write an integration like they did for home assistant.

I looked at the home assistant integration, and it looks pretty straightforward actually. I just don't have time to make a new integration for hubitat right now.

Not another hub!!!!! :flushed:
Only joking.

1 Like

Download the Hubitat app